summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-06-26 22:15:38 +0200
committerSam James <sam@gentoo.org>2022-06-28 10:30:09 +0100
commit83df2c4feae6ef4e6bdcb77bdcdaf6d33fb7d1fd (patch)
treee185f6efeb7b9fdd2e307a4c74c58a0e47179bdf
parentdev-python/ipyparallel: increase timeouts for new tests in 8.3.0 (diff)
downloadgentoo-83df2c4feae6ef4e6bdcb77bdcdaf6d33fb7d1fd.tar.gz
gentoo-83df2c4feae6ef4e6bdcb77bdcdaf6d33fb7d1fd.tar.bz2
gentoo-83df2c4feae6ef4e6bdcb77bdcdaf6d33fb7d1fd.zip
dev-util/gef: version bump 2022.06
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26085 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/gef/Manifest1
-rw-r--r--dev-util/gef/gef-2022.06.ebuild85
-rw-r--r--dev-util/gef/gef-9999.ebuild18
3 files changed, 97 insertions, 7 deletions
diff --git a/dev-util/gef/Manifest b/dev-util/gef/Manifest
index baac8a70b5e9..49ae2c4a2659 100644
--- a/dev-util/gef/Manifest
+++ b/dev-util/gef/Manifest
@@ -1,2 +1,3 @@
DIST gef-2021.10.tar.gz 170829 BLAKE2B 4d21fb68b2d9239dea912bb41790c7ffe83d9a7bb17cc6b3df67078b0147ff06676ff257c46567fb9a4fa76d5e12140f567f153337e83dbdd10cf0576cd08499 SHA512 30ccc728322651c3fc88f629165a96f593f079ddaa21d194e483804cdf4bcb235ed28cfaaa6fdd85c134b2314f32bd87e3dcf5decc45720f8e7b89ca9af2c379
DIST gef-2022.01.tar.gz 211779 BLAKE2B 1cb501cc7e05b1f96bb1d3ea42c8970273aea717b927f90120dbc5d0b5d9d7e28a89d1b1eb8a969406dfcd4f06f23e703e3aaa27a5a294b0d454d41b82b7bd12 SHA512 4e89ab889933464711c7a990df7fe6a6c014b80e9f5ad5e77382c3938413d31d03838e2215225defae88008b2ca0e577edeb01189189ea5e37d07204375fb47b
+DIST gef-2022.06.tar.gz 217503 BLAKE2B b7038e0519f216669c38bdda7e12375fb1c9e5278c8b617df73932a750ee6552531929eebcac22321607f51592834ece70c850ce0ba4629bc383731bc8803bb3 SHA512 585bad8655a5208d060b1ccf455ab87527e47949fce1df188a5ac970ccd1bbfbdd87151f7a940edcfb879dd0ea846b5c4a8650fed856cd5dcaec0ddd3581f100
diff --git a/dev-util/gef/gef-2022.06.ebuild b/dev-util/gef/gef-2022.06.ebuild
new file mode 100644
index 000000000000..f6f2afc9a0ad
--- /dev/null
+++ b/dev-util/gef/gef-2022.06.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit python-single-r1 wrapper
+
+DESCRIPTION="A GDB Enhanced Features for exploit devs & reversers"
+HOMEPAGE="https://github.com/hugsy/gef"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hugsy/gef"
+else
+ SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+# Seem to hang right now?
+RESTRICT="!test? ( test ) test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ropper[${PYTHON_SINGLE_USEDEP}]
+ sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-util/unicorn[python,${PYTHON_USEDEP}]
+ ')"
+
+BDEPEND="
+ doc? (
+ dev-python/mkdocs
+ dev-python/mkdocs-material
+ )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )"
+
+src_prepare() {
+ default
+
+ sed -i -e '/pylint/d' tests/requirements.txt || die
+}
+
+src_compile() {
+ # Tries to compile tests
+ :
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r *.py
+
+ python_optimize "${ED}/usr/share/${PN}"
+
+ make_wrapper "gdb-gef" \
+ "gdb -x \"/usr/share/${PN}/gef.py\"" || die
+
+ if use doc; then
+ # TODO: docs.eclass?
+ mkdocs build -d html || die
+
+ rm "${WORKDIR}/${P}/html/sitemap.xml.gz" || die
+ dodoc -r html/
+ fi
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ einfo "\nUsage:"
+ einfo " ~$ gdb-gef <program>\n"
+}
diff --git a/dev-util/gef/gef-9999.ebuild b/dev-util/gef/gef-9999.ebuild
index e29ca85b5b66..f6f2afc9a0ad 100644
--- a/dev-util/gef/gef-9999.ebuild
+++ b/dev-util/gef/gef-9999.ebuild
@@ -10,7 +10,7 @@ inherit python-single-r1 wrapper
DESCRIPTION="A GDB Enhanced Features for exploit devs & reversers"
HOMEPAGE="https://github.com/hugsy/gef"
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hugsy/gef"
else
@@ -36,7 +36,11 @@ RDEPEND="
dev-util/unicorn[python,${PYTHON_USEDEP}]
')"
-BDEPEND="doc? ( dev-python/mkdocs )
+BDEPEND="
+ doc? (
+ dev-python/mkdocs
+ dev-python/mkdocs-material
+ )
test? (
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
@@ -47,7 +51,7 @@ BDEPEND="doc? ( dev-python/mkdocs )
src_prepare() {
default
- sed -i -e '/pylint/d' requirements.txt || die
+ sed -i -e '/pylint/d' tests/requirements.txt || die
}
src_compile() {
@@ -56,19 +60,19 @@ src_compile() {
}
src_install() {
- insinto /usr/share/${PN}
+ insinto "/usr/share/${PN}"
doins -r *.py
- python_optimize "${ED}"/usr/share/${PN}
+ python_optimize "${ED}/usr/share/${PN}"
make_wrapper "gdb-gef" \
- "gdb -ex \"source ${EPREFIX}/usr/share/${PN}/gef.py\"" || die
+ "gdb -x \"/usr/share/${PN}/gef.py\"" || die
if use doc; then
# TODO: docs.eclass?
mkdocs build -d html || die
- rm "${WORKDIR}"/${P}/html/sitemap.xml.gz || die
+ rm "${WORKDIR}/${P}/html/sitemap.xml.gz" || die
dodoc -r html/
fi