summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-13 16:16:51 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-13 16:17:19 +0100
commit8409d3195a71a22be4dae5cf0a661a9facb24d97 (patch)
tree8c756bb9517b6f5ef2ffab836437f6dbf5df8cc6
parentdev-libs/kqoauth: removed older Qt4 versions (diff)
downloadgentoo-8409d3195a71a22be4dae5cf0a661a9facb24d97.tar.gz
gentoo-8409d3195a71a22be4dae5cf0a661a9facb24d97.tar.bz2
gentoo-8409d3195a71a22be4dae5cf0a661a9facb24d97.zip
www-client/surf: EAPI 6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--www-client/surf/surf-0.7-r1.ebuild73
-rw-r--r--www-client/surf/surf-9999.ebuild15
2 files changed, 83 insertions, 5 deletions
diff --git a/www-client/surf/surf-0.7-r1.ebuild b/www-client/surf/surf-0.7-r1.ebuild
new file mode 100644
index 000000000000..ea3c9d847241
--- /dev/null
+++ b/www-client/surf/surf-0.7-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7-gentoo.patch
+)
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+ fi
+}
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index cf2697d9a9b5..e685de4fbadb 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils git-2 savedconfig toolchain-funcs
+EAPI=6
+inherit git-r3 savedconfig toolchain-funcs
DESCRIPTION="a simple web browser based on WebKit/GTK+"
HOMEPAGE="http://surf.suckless.org/"
@@ -34,6 +34,9 @@ RDEPEND="
x11-terms/st
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
pkg_setup() {
if ! use savedconfig; then
@@ -49,13 +52,15 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch_user
+ default
+
restore_config config.h
+
tc-export CC PKG_CONFIG
}
src_install() {
default
+
save_config config.h
}