summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:15:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:42 +0100
commit8459f073ee0e617da58506178c82f16bd63e52d9 (patch)
tree939bf6f9b083ab7e4f58f9d2f0c88cb00fcd0640
parentapp-doc/NaturalDocs: Stabilize 1.52-r1 ppc64, #658354 (diff)
downloadgentoo-8459f073ee0e617da58506178c82f16bd63e52d9.tar.gz
gentoo-8459f073ee0e617da58506178c82f16bd63e52d9.tar.bz2
gentoo-8459f073ee0e617da58506178c82f16bd63e52d9.zip
dev-python/hypothesis: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.0.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 5b03e065e843..679ae988a777 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-5.43.4.tar.gz 9104105 BLAKE2B 08b8c9ac7ac72afcc4556ae2167
DIST hypothesis-python-5.47.0.tar.gz 9101964 BLAKE2B 7f57eebb6f27bf57373f2560612458bf9fd6233f8a9f254e59ced22c070a6f00453036c09b4e224b340843ad5027a9217e83473aaa13c1f94d354408d8d28799 SHA512 6a72469f0c2d0f16ddb56846a96f584104e726e4cd459abe30a744aef20ff50811e00e2a0feb72a3e3e6a3c6c7a7bf15be7c633640350e3bd550ad145c97c693
DIST hypothesis-python-5.48.0.tar.gz 9102665 BLAKE2B 985957be8e13ada8830bc9c8c3941d8ecec0ef3d3684a177aa4d9cc10c1d57972ddef9f5b35194197ede2d1e5932299a9a99f04eabe6dd8789a786300d1b5608 SHA512 b4d46db6aa9c3dc59f38e209b702580ce9fa0d8771792943cbe28fcca4ea434c23a6f49b9889cb28339d7282e529f1c947a7768c38d726b5e993a2ba3c029e00
DIST hypothesis-python-5.49.0.tar.gz 9103591 BLAKE2B 158cbc38f6f2407d437656a7b94b5826193d427e06eca59d91b3fe85667282ec3392d72e7bbdf2bd952a495871a86814275883e2dcbc80758fcb3e68936d6d20 SHA512 96b7f98e7d87f82dac52a7b2de2bc0c29507cee05ee9a93f838e090e45a9f484ca75db1ab83ab52361b27e4e0f2747914ec09324fc188f6100c3397b1596778c
+DIST hypothesis-python-6.0.0.tar.gz 9103769 BLAKE2B 91ce33c4370530611f1c14abdaf8760a4e40b314ee01bf9536e0ee6b618f1191b0173cf8f65f78fb31ccb23331d5c12779703f94fa85b4d648d9b879762bd8b0 SHA512 c06d95fd889a0560325435787344a5d57041269e5ea4945dac4517ccf04b0b2aa58ae06058937640b208c5433fc0ff3d81c958baca5a5d9100a8f058aeccf41e
diff --git a/dev-python/hypothesis/hypothesis-6.0.0.ebuild b/dev-python/hypothesis/hypothesis-6.0.0.ebuild
new file mode 100644
index 000000000000..b910c24f12a5
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}