summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-09 21:40:44 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-09 21:40:44 -0700
commit84832fd6083888396af61b1587ed01943a38b326 (patch)
tree1bd94f68865ab72d33f39f8898829680868a6d87
parentmedia-video/ffmpeg: sync ppc changes to live ebuild (diff)
downloadgentoo-84832fd6083888396af61b1587ed01943a38b326.tar.gz
gentoo-84832fd6083888396af61b1587ed01943a38b326.tar.bz2
gentoo-84832fd6083888396af61b1587ed01943a38b326.zip
sci-libs/fftw: re-add CPU_FLAGS_PPC
changes made in 480391553a377349046f7fd2b62e2df37ef29752 were lost in 67a3fff18cedaf357e1a8cff0eae5f8aaf4824eb re-add them back Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sci-libs/fftw/fftw-3.3.8-r1.ebuild4
-rw-r--r--sci-libs/fftw/fftw-3.3.8.ebuild6
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/sci-libs/fftw/fftw-3.3.8-r1.ebuild b/sci-libs/fftw/fftw-3.3.8-r1.ebuild
index f8105f1e1b41..150c67d958e3 100644
--- a/sci-libs/fftw/fftw-3.3.8-r1.ebuild
+++ b/sci-libs/fftw/fftw-3.3.8-r1.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2+"
SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -94,7 +94,7 @@ multilib_src_configure() {
# altivec, sse, single-paired only work for single
myconf+=(
--enable-single
- $(use_enable altivec)
+ $(use_enable cpu_flags_ppc_altivec altivec)
$(use_enable cpu_flags_x86_avx avx)
$(use_enable cpu_flags_x86_avx2 avx2)
$(use_enable cpu_flags_x86_sse sse)
diff --git a/sci-libs/fftw/fftw-3.3.8.ebuild b/sci-libs/fftw/fftw-3.3.8.ebuild
index b0783f5d9cb0..e54af4af14bf 100644
--- a/sci-libs/fftw/fftw-3.3.8.ebuild
+++ b/sci-libs/fftw/fftw-3.3.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2+"
SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -94,7 +94,7 @@ multilib_src_configure() {
# altivec, sse, single-paired only work for single
myconf+=(
--enable-single
- $(use_enable altivec)
+ $(use_enable cpu_flags_ppc_altivec altivec)
$(use_enable cpu_flags_x86_avx avx)
$(use_enable cpu_flags_x86_avx2 avx2)
$(use_enable cpu_flags_x86_sse sse)
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index 9266b28d174d..d92ed1ac2ad5 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2+"
SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -94,7 +94,7 @@ multilib_src_configure() {
# altivec, sse, single-paired only work for single
myconf+=(
--enable-single
- $(use_enable altivec)
+ $(use_enable cpu_flags_ppc_altivec altivec)
$(use_enable cpu_flags_x86_avx avx)
$(use_enable cpu_flags_x86_avx2 avx2)
$(use_enable cpu_flags_x86_sse sse)