summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-04 12:44:32 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-05 19:26:13 +0000
commit855460449379abdc9c33dc1dabc833ef13e5192c (patch)
treea966095ee33269c0ef386fca665dc21b75243df6
parentnet-p2p/deluge: Fix dependency on net-libs/rb_libtorrent. (diff)
downloadgentoo-855460449379abdc9c33dc1dabc833ef13e5192c.tar.gz
gentoo-855460449379abdc9c33dc1dabc833ef13e5192c.tar.bz2
gentoo-855460449379abdc9c33dc1dabc833ef13e5192c.zip
net-analyzer/wireshark: Explicitely depend on media-libs/speex with USE=qt5
Configure checks for speex presents when using QT and automatically uses it without control via USE. This results in 'preserved libs' when removing speex Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--net-analyzer/wireshark/metadata.xml44
-rw-r--r--net-analyzer/wireshark/wireshark-2.2.3.ebuild3
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild3
3 files changed, 26 insertions, 24 deletions
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index b539ed354f3e..b72cb57da065 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
-<email>netmon@gentoo.org</email>
-<name>Gentoo network monitoring and analysis project</name>
-</maintainer>
-<longdescription>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <longdescription>
Wireshark is the world's foremost network protocol analyzer, and is the de
facto (and often de jure) standard across many industries and educational
institutions. Wireshark has a rich feature set which includes 1) deep
@@ -27,21 +27,21 @@
intuitive analysis, 12) output can be exported to XML, PostScript®, CSV, or
plain text
</longdescription>
-<use>
-<flag name="adns">Use the GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
-<flag name="androiddump">Install androiddump, an extcap interface to capture from Android devices</flag>
-<flag name="ciscodump">Install ciscodump, extcap interface to capture from a remote Cisco router</flag>
-<flag name="crypt">Use <pkg>dev-libs/libgcrypt</pkg> to decrypt traffic</flag>
-<flag name="doc-pdf">Build documentation in pdf format (US and a4 paper sizes)</flag>
-<flag name="libssh">Use <pkg>net-libs/libssh</pkg> (for sshdump)</flag>
-<flag name="netlink">Use <pkg>dev-libs/libnl</pkg></flag>
-<flag name="pcap">Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
-<flag name="qt4">Build the wireshark executable with an experimental Qt UI instead of GTK+.</flag>
-<flag name="randpkt">Install randpkt, a utility for creating pcap trace files full of random packets</flag>
-<flag name="randpktdump">Install randpktdump, an extcap interface to provide access to the random packet generator (randpkt)</flag>
-<flag name="sbc">Use <pkg>media-libs/sbc</pkg> for playing back SBC encoded packets</flag>
-<flag name="smi">Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
-<flag name="sshdump">Install sshdump, an extcap interface to capture from a remote host through SSH</flag>
-<flag name="tfshark">Install tfshark, a terminal-based version of the FileShark capability</flag>
-</use>
+ <use>
+ <flag name="adns">Use the GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
+ <flag name="androiddump">Install androiddump, an extcap interface to capture from Android devices</flag>
+ <flag name="ciscodump">Install ciscodump, extcap interface to capture from a remote Cisco router</flag>
+ <flag name="crypt">Use <pkg>dev-libs/libgcrypt</pkg> to decrypt traffic</flag>
+ <flag name="doc-pdf">Build documentation in pdf format (US and a4 paper sizes)</flag>
+ <flag name="libssh">Use <pkg>net-libs/libssh</pkg> (for sshdump)</flag>
+ <flag name="netlink">Use <pkg>dev-libs/libnl</pkg></flag>
+ <flag name="pcap">Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
+ <flag name="qt4">Build the wireshark executable with an experimental Qt UI instead of GTK+.</flag>
+ <flag name="randpkt">Install randpkt, a utility for creating pcap trace files full of random packets</flag>
+ <flag name="randpktdump">Install randpktdump, an extcap interface to provide access to the random packet generator (randpkt)</flag>
+ <flag name="sbc">Use <pkg>media-libs/sbc</pkg> for playing back SBC encoded packets</flag>
+ <flag name="smi">Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
+ <flag name="sshdump">Install sshdump, an extcap interface to capture from a remote host through SSH</flag>
+ <flag name="tfshark">Install tfshark, a terminal-based version of the FileShark capability</flag>
+ </use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-2.2.3.ebuild b/net-analyzer/wireshark/wireshark-2.2.3.ebuild
index 86dcffcd766a..e550ae2b51cf 100644
--- a/net-analyzer/wireshark/wireshark-2.2.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -55,6 +55,7 @@ CDEPEND="
dev-qt/qtmultimedia:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
+ media-libs/speex
x11-misc/xdg-utils
)
sbc? ( media-libs/sbc )
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 87ee793f9b90..671d50cce76f 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,6 +47,7 @@ CDEPEND="
dev-qt/qtmultimedia:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
+ media-libs/speex
x11-misc/xdg-utils
)
sbc? ( media-libs/sbc )