summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-07-19 13:25:26 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-07-19 13:26:57 +0200
commit85907a4f0d6e1d14205ffba74dff5516487e8a4f (patch)
treeaea7617025c2329dd8294ff724a0f38175053497
parentnet-p2p/nicotine+: take over. (diff)
downloadgentoo-85907a4f0d6e1d14205ffba74dff5516487e8a4f.tar.gz
gentoo-85907a4f0d6e1d14205ffba74dff5516487e8a4f.tar.bz2
gentoo-85907a4f0d6e1d14205ffba74dff5516487e8a4f.zip
net-p2p/nicotine+: 2.0.1 bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-2.0.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 047e9967a8a4..eb5ab027577e 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1 +1,2 @@
DIST nicotine+-1.4.1.tar.gz 3824830 BLAKE2B def211a4d06b1cb6a409917579652b3a1c8c36ec5ecfe5e295b9fabeaaca02cd4999fd20935c8999d4cf989f3ecff0a0a2c7f52a40f8c2b03e05b6c9dc2feca9 SHA512 894dfb318b205b6be21face0308f183da15772f329158c6a9a8a816dfdf231ad89245188acad5538821b2a778c8a8a6201ce8548cc58550c4eb6c0763db9d66a
+DIST nicotine+-2.0.1.tar.gz 5140065 BLAKE2B 01af7eb58ea6800c17042ef73b9caa8b3d5712e33226486e648fee824c0d0934440ee51f659199a5276f6a460005df89359b282b09aa07941c70e29bddc97a26 SHA512 0a16c0c289a4f4d54eba773ad40952baadf73333ea4a6b4a4524cc500d007f6de0bdd7a847e3f68978a3247c9bc4a6eab3b77db34605fda79da34c352e89a1b9
diff --git a/net-p2p/nicotine+/nicotine+-2.0.1.ebuild b/net-p2p/nicotine+/nicotine+-2.0.1.ebuild
new file mode 100644
index 000000000000..ac77a1b3f005
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}