summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-16 23:16:37 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-16 23:49:29 +0200
commit870ba927b664bb72be14063cac451dbcc75182e7 (patch)
treec2607d5f2418395f0a6cdb5400215efc31bf88af
parentsci-physics/h2o-gtk: Migrate to GitHub (diff)
downloadgentoo-870ba927b664bb72be14063cac451dbcc75182e7.tar.gz
gentoo-870ba927b664bb72be14063cac451dbcc75182e7.tar.bz2
gentoo-870ba927b664bb72be14063cac451dbcc75182e7.zip
sci-physics/h2o-gtk: Bump to EAPI 7
-rw-r--r--sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild23
-rw-r--r--sci-physics/h2o-gtk/h2o-gtk-9999.ebuild11
2 files changed, 30 insertions, 4 deletions
diff --git a/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild b/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
new file mode 100644
index 000000000000..ec3885a327dc
--- /dev/null
+++ b/sci-physics/h2o-gtk/h2o-gtk-0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GTK+ UI for libh2o -- water & steam properties"
+HOMEPAGE="https://github.com/mgorny/h2o-gtk/"
+SRC_URI="https://github.com/mgorny/h2o-gtk/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/gtkmm:2.4=
+ sci-libs/libh2oxx:0=
+ sci-libs/plotmm:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -x CXXFLAGS="${CXXFLAGS} -std=c++11"
+ default
+}
diff --git a/sci-physics/h2o-gtk/h2o-gtk-9999.ebuild b/sci-physics/h2o-gtk/h2o-gtk-9999.ebuild
index dd9d42e7722f..1096a19fbbc2 100644
--- a/sci-physics/h2o-gtk/h2o-gtk-9999.ebuild
+++ b/sci-physics/h2o-gtk/h2o-gtk-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils git-r3
+inherit autotools git-r3
DESCRIPTION="GTK+ UI for libh2o -- water & steam properties"
HOMEPAGE="https://github.com/mgorny/h2o-gtk/"
@@ -21,3 +19,8 @@ RDEPEND="dev-cpp/gtkmm:2.4=
sci-libs/libh2oxx:0=
sci-libs/plotmm:0="
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}