summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 10:57:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 10:58:10 +0200
commit8720263cf7e75d8fc264ba028a76f7236b09f067 (patch)
tree00f7f3d1bfd07ee6f825923173f29e6c0438ec7a
parentdev-python/google-auth: Bump to 1.29.0 (diff)
downloadgentoo-8720263cf7e75d8fc264ba028a76f7236b09f067.tar.gz
gentoo-8720263cf7e75d8fc264ba028a76f7236b09f067.tar.bz2
gentoo-8720263cf7e75d8fc264ba028a76f7236b09f067.zip
sys-devel/clang: Disable CUDA target autodetection
CUDA target autodetection causes sandbox failures, and even if it did not, it would cause the package to be set for build host's video card. Force the CUDA package detection to fail, in order to disable that. Closes: https://bugs.gentoo.org/760645 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang/clang-12.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang/clang-12.0.0.ebuild3
-rw-r--r--sys-devel/clang/clang-13.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-12.0.0.9999.ebuild b/sys-devel/clang/clang-12.0.0.9999.ebuild
index f0164c6eaeab..bd58b0be005c 100644
--- a/sys-devel/clang/clang-12.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-12.0.0.9999.ebuild
@@ -258,6 +258,9 @@ multilib_src_configure() {
# furthermore, it provides only syntax checking
-DCLANG_DEFAULT_OPENMP_RUNTIME=libomp
+ # disable using CUDA to autodetect GPU, just build for all
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=ON
+
# override default stdlib and rtlib
-DCLANG_DEFAULT_CXX_STDLIB=$(usex default-libcxx libc++ "")
-DCLANG_DEFAULT_RTLIB=$(usex default-compiler-rt compiler-rt "")
diff --git a/sys-devel/clang/clang-12.0.0.ebuild b/sys-devel/clang/clang-12.0.0.ebuild
index d983e2ed06f3..5feec724ffce 100644
--- a/sys-devel/clang/clang-12.0.0.ebuild
+++ b/sys-devel/clang/clang-12.0.0.ebuild
@@ -258,6 +258,9 @@ multilib_src_configure() {
# furthermore, it provides only syntax checking
-DCLANG_DEFAULT_OPENMP_RUNTIME=libomp
+ # disable using CUDA to autodetect GPU, just build for all
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=ON
+
# override default stdlib and rtlib
-DCLANG_DEFAULT_CXX_STDLIB=$(usex default-libcxx libc++ "")
-DCLANG_DEFAULT_RTLIB=$(usex default-compiler-rt compiler-rt "")
diff --git a/sys-devel/clang/clang-13.0.0.9999.ebuild b/sys-devel/clang/clang-13.0.0.9999.ebuild
index f0164c6eaeab..bd58b0be005c 100644
--- a/sys-devel/clang/clang-13.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-13.0.0.9999.ebuild
@@ -258,6 +258,9 @@ multilib_src_configure() {
# furthermore, it provides only syntax checking
-DCLANG_DEFAULT_OPENMP_RUNTIME=libomp
+ # disable using CUDA to autodetect GPU, just build for all
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUDA=ON
+
# override default stdlib and rtlib
-DCLANG_DEFAULT_CXX_STDLIB=$(usex default-libcxx libc++ "")
-DCLANG_DEFAULT_RTLIB=$(usex default-compiler-rt compiler-rt "")