summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-28 18:27:21 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-29 09:14:30 +0100
commit88b629ccf5b0a80ee47a69444c19df6b60efd230 (patch)
treee87d579f6d5145cf4aa1fbdd023f35d7ca33673d
parentapp-portage/esearch: Replace python_export_best (diff)
downloadgentoo-88b629ccf5b0a80ee47a69444c19df6b60efd230.tar.gz
gentoo-88b629ccf5b0a80ee47a69444c19df6b60efd230.tar.bz2
gentoo-88b629ccf5b0a80ee47a69444c19df6b60efd230.zip
dev-lang/yasm: Use python_setup instead of python_export_best
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-lang/yasm/yasm-1.2.0-r1.ebuild2
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild2
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild4
3 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/yasm/yasm-1.2.0-r1.ebuild b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
index be32d57759d7..9cd5c98942fb 100644
--- a/dev-lang/yasm/yasm-1.2.0-r1.ebuild
+++ b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
@@ -37,7 +37,7 @@ src_prepare() {
}
src_configure() {
- use python && python_export_best
+ use python && python_setup
econf \
$(use_enable python) \
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
index cee1a7f6f93e..e1ef59791ee0 100644
--- a/dev-lang/yasm/yasm-1.3.0.ebuild
+++ b/dev-lang/yasm/yasm-1.3.0.ebuild
@@ -26,7 +26,7 @@ DEPEND="
python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
src_configure() {
- use python && python_export_best
+ use python && python_setup
XMLTO=: \
econf \
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index c667fd21f2b2..1dc81bc993d4 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -50,9 +50,9 @@ src_prepare() {
src_configure() {
if [[ ${PV} == 9999* ]]; then
- python_export_best
+ python_setup
else
- use python && python_export_best
+ use python && python_setup
fi
econf \