summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-18 10:58:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-18 18:13:31 +0300
commit8930172cdb8f9347eadc2e03bce57bf781c35ec7 (patch)
treeb2224e602e5e91f82172c17767741d275e0537af
parentmedia-libs/hamlib: Version bump (diff)
downloadgentoo-8930172cdb8f9347eadc2e03bce57bf781c35ec7.tar.gz
gentoo-8930172cdb8f9347eadc2e03bce57bf781c35ec7.tar.bz2
gentoo-8930172cdb8f9347eadc2e03bce57bf781c35ec7.zip
dev-python/PyECLib: cleanup, EAPI=8, enable test
Closes: https://bugs.gentoo.org/730234 Closes: https://bugs.gentoo.org/737858 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/PyECLib/PyECLib-1.6.0-r1.ebuild37
-rw-r--r--dev-python/PyECLib/PyECLib-1.6.0.ebuild24
2 files changed, 37 insertions, 24 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.6.0-r1.ebuild b/dev-python/PyECLib/PyECLib-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..487777ee0854
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.6.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="https://pypi.org/project/PyECLib/"
+SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
+S="${WORKDIR}/pyeclib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+DEPEND="dev-libs/liberasurecode"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # https://review.opendev.org/c/openstack/pyeclib/+/798010
+ sed -e '/library_dirs/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "jerasure backend" dev-libs/jerasure
+}
diff --git a/dev-python/PyECLib/PyECLib-1.6.0.ebuild b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
deleted file mode 100644
index a333cdf73126..000000000000
--- a/dev-python/PyECLib/PyECLib-1.6.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-
-inherit distutils-r1 multilib
-
-DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
-HOMEPAGE="https://pypi.org/project/PyECLib/"
-SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
-S="${WORKDIR}/pyeclib-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-libs/jerasure"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="dev-libs/liberasurecode
- ${CDEPEND}"