summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 19:39:24 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 19:50:14 -0800
commit8984c5b5d033f874427cb0d4d9b661d1a00d65ca (patch)
tree07e0993669e07c7b7f1c4f6e8599212b8cd01a6d
parentdev-python/contextlib2: verbump to 0.6.0, add py38, add RESTRICT (diff)
downloadgentoo-8984c5b5d033f874427cb0d4d9b661d1a00d65ca.tar.gz
gentoo-8984c5b5d033f874427cb0d4d9b661d1a00d65ca.tar.bz2
gentoo-8984c5b5d033f874427cb0d4d9b661d1a00d65ca.zip
dev-python/path-py: Version bump to 11.5.2
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/files/path-py-11.5.2-tests.patch15
-rw-r--r--dev-python/path-py/path-py-11.5.2.ebuild49
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 4685c2430d12..ab7b9442e498 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,4 +1,5 @@
DIST path.py-10.3.1.tar.gz 35871 BLAKE2B 94e45372ad39f9c5dfe4167f5d1fd58e1e501272ed2fa5ecd116f0fffc7b924c66cc436a83a296a167c08bb2f57f169b1ace7692c2ac1284fc9070918b409a3c SHA512 e8dc874521aee6cadc5e3d7a66ca6909010f2069b1e6ed0298a3dbd86466c971ca466b442bff90906cb891fa9f13190fd9b3bf4ae62442e9fe73909169c32c02
DIST path.py-11.0.1.tar.gz 38348 BLAKE2B 80bfc308c72f0e2867ce1811709e3d2ff63888be53814e026ee221c381387a581f8e0f8da05e5c1fade2e0d6b93ba930dc9b1f38117667239174a3acc85d76f0 SHA512 48bc8352af74e70e702e712f35f08a0bf05713b2de5f2eb617f8ef2f9138344cf74fab453aff6cbd38bd88f5c3612c39b3605e0d3899c2ab1c667662558a8651
+DIST path.py-11.5.2.tar.gz 43542 BLAKE2B 6b376eebf5b9197c4a2e23ee25c8261c7a8b9428007a626bc0f7d1be71496f4abf7fc6f11cee628432304e6a684bd690d6895f325981c4dd0092bdf3c4a4a4e3 SHA512 8a76ffd7d369adb4c5cbc25f2a52c5cabe899bf59d248d217fc5a086e45438d9dfe6b65b63aa2c89edd7662a793d213662cd6726d15f5ce49dc6bdaf22425865
DIST path.py-12.0.2.tar.gz 44859 BLAKE2B c82bfd248e0e6eb21e3416c86f7a3a5fbfc5f5b327fe20da4084c53f22834013fc224bfbcf455690f53002c8f1c3e060aa0f04f3792e749dad62e51702cea348 SHA512 97971fa1e6bcdd4acf057ab4fe6cde2edb9d9d3d06dc049ea3779cae867221ae3e9d905daa1ec706f867473f738bb328b2795d3030244f8bd8ff7e8f0d5a6b2c
DIST path.py-8.1.2.tar.gz 33437 BLAKE2B 0033b64e9d0f4c719414e5345989308a113c9e23f99fb46722ee7d7de85c7bb4b471f5416d646d943771cdd369ac2d8f23f925660d4212b18acf7b82daaa76c0 SHA512 639b6247d99bd7c88e7505f5f41a5896266f23c0517b470ea5c1ec90ca76e87f1971babee623bbd7bea57bbef5f7677a7163bc51bae78c3c54e978eaf7f122d1
diff --git a/dev-python/path-py/files/path-py-11.5.2-tests.patch b/dev-python/path-py/files/path-py-11.5.2-tests.patch
new file mode 100644
index 000000000000..4760b20d3cb4
--- /dev/null
+++ b/dev-python/path-py/files/path-py-11.5.2-tests.patch
@@ -0,0 +1,15 @@
+diff --git a/test_path.py b/test_path.py
+index 2a7ddb8..cc7a58f 100644
+--- a/test_path.py
++++ b/test_path.py
+@@ -420,6 +420,10 @@ class TestScratchDir:
+ platform.system() == 'Windows' and path.PY3,
+ reason="Can't write latin characters. See #133",
+ )
++ @pytest.mark.xfail(
++ path.PY2,
++ reason="Broken on python 2.7",
++ )
+ def test_listdir_other_encoding(self, tmpdir):
+ """
+ Some filesystems allow non-character sequences in path names.
diff --git a/dev-python/path-py/path-py-11.5.2.ebuild b/dev-python/path-py/path-py-11.5.2.ebuild
new file mode 100644
index 000000000000..bae80335185f
--- /dev/null
+++ b/dev-python/path-py/path-py-11.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path.py/ https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{5,6,7} pypy3)
+ dev-python/appdirs[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/path-py-11.5.2-tests.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
+
+ # disable flake8 tests
+ sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
+ pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. pytest -v || die
+}