summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-01-23 11:35:46 +0100
committerSam James <sam@gentoo.org>2021-01-24 13:29:18 +0000
commit898c7530b63c3119c598cd7596dfbef75cbecfd7 (patch)
tree6b4d93532553986f99497596cd7cb88611e96937
parentdev-ml/ppx_typerep_conv: add ml maintainer (diff)
downloadgentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.tar.gz
gentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.tar.bz2
gentoo-898c7530b63c3119c598cd7596dfbef75cbecfd7.zip
dev-python/nuitka: bump version to 0.6.11
Also, added tests to the ebuild. Closes: https://bugs.gentoo.org/762730 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.11.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 1d8fe788b653..bae76e0db599 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
+DIST Nuitka-0.6.11.tar.gz 2582563 BLAKE2B e65c3a01f3283b24aadefc47a17a41ebae116265946c24f2225fa7f3f6f824a0a822c76aa2fa1ff33b5a00d4d3762bbac7cd0d090d2627274155b13a48d8f0ba SHA512 c1ead8430f0af3a20d7a14ae3cb34b9a4675c18f0c775e8833b5722cb0acdd8213b28639e52067b3e6758b8b6cc516b05151cfd85560630c92b872dae05a88b4
DIST Nuitka-0.6.9.1.tar.gz 2470517 BLAKE2B b3162eed308d98846a6266fa822d851757773ef9910a250644d61627d70dcc29706f5127221e2c09b1f856b74262c64f10cc638ec336a53d1fd6a10ad53e4e29 SHA512 a94a2e7f86abdbbdaa0147e569ff873c4d0f439378afb0f55ce78ea6e22a16ac759b62fd617944e0a4cf98fbe3294db5e56c3b3a6bd8cb78bd1c1132d557f6a9
DIST Nuitka-0.6.9.6.tar.gz 2472086 BLAKE2B acee6dc787f24afb6c1843e82bd4fdcda3a45c4c8a74cb5635d5fb2aec6b1a8db64920993b1732e21f3d0866e47f81cd958f42fe577c592931053248976ab33a SHA512 9a4d2b0e947e26118c9e81fc93c63ccc344a0a4d577e2ccd2d6b1ccafacef3eb3d7424283e681b63dde44fa51aad84d86f76e2c839d22d7d1503730e0ab72ab8
diff --git a/dev-python/nuitka/nuitka-0.6.11.ebuild b/dev-python/nuitka/nuitka-0.6.11.ebuild
new file mode 100644
index 000000000000..c23425d68d01
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+
+RDEPEND="${BDEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+S="${WORKDIR}/${P^}"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}