summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-08-08 06:05:31 +1000
committerSam James <sam@gentoo.org>2022-08-10 04:34:47 +0100
commit8b387a8cacca6f6f7cb05094642a3ce13a74c1b3 (patch)
tree8ea2e4059570d59f66bda0aeb048caa3455bbf73
parentdev-haskell/wai: drop 3.2.2.1 (diff)
downloadgentoo-8b387a8cacca6f6f7cb05094642a3ce13a74c1b3.tar.gz
gentoo-8b387a8cacca6f6f7cb05094642a3ce13a74c1b3.tar.bz2
gentoo-8b387a8cacca6f6f7cb05094642a3ce13a74c1b3.zip
dev-haskell/path: hard-disable dev USE flag
Bug: https://bugs.gentoo.org/864202 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/path/path-0.9.2-r1.ebuild (renamed from dev-haskell/path/path-0.9.2.ebuild)15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-haskell/path/path-0.9.2.ebuild b/dev-haskell/path/path-0.9.2-r1.ebuild
index 71683620a480..74a159e8e4ca 100644
--- a/dev-haskell/path/path-0.9.2.ebuild
+++ b/dev-haskell/path/path-0.9.2-r1.ebuild
@@ -3,40 +3,35 @@
EAPI=8
-# ebuild generated by hackport 0.7.9999
-#hackport: flags: -validity
+# ebuild generated by hackport 0.7.2.1.9999
+#hackport: flags: -validity,-dev
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Support for well-typed paths"
HOMEPAGE="https://hackage.haskell.org/package/path"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="dev"
RDEPEND="dev-haskell/aeson:=[profile?]
- >=dev-haskell/exceptions-0.4:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
>=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
- dev-haskell/text:=[profile?]
- >=dev-lang/ghc-8.6.3:=
+ >=dev-lang/ghc-8.10.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.4.0.1
+ >=dev-haskell/cabal-3.2.0.0
test? ( >=dev-haskell/genvalidity-1.0
>=dev-haskell/genvalidity-hspec-0.7
>=dev-haskell/genvalidity-property-0.4
>=dev-haskell/hspec-2.0 <dev-haskell/hspec-3
- >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3
dev-haskell/quickcheck
>=dev-haskell/validity-0.8.0.0 )
"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag dev dev) \
+ --flag=-dev \
--flag=-validity
}