summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-08 15:59:36 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-08 16:05:09 +0200
commit8b7958b7c10c6f5d293ce3bb42b295abf9df58e8 (patch)
treeceb84959d6d3c8df06d7ce832fd8a6e493f59929
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-8b7958b7c10c6f5d293ce3bb42b295abf9df58e8.tar.gz
gentoo-8b7958b7c10c6f5d293ce3bb42b295abf9df58e8.tar.bz2
gentoo-8b7958b7c10c6f5d293ce3bb42b295abf9df58e8.zip
sys-libs/llvm-libunwind: Add missing MULTILIB_USEDEP on sys-devel/llvm
Add MULTILIB_USEDEP on sys-devel/llvm since the needed CMake files are installed in ABI-specific lib* directory.
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild
index ba30c8034791..1346f7ab91b7 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild
@@ -21,7 +21,7 @@ IUSE="debug +static-libs"
RDEPEND="!sys-libs/libunwind"
# llvm-config and cmake files needed to get proper flags
# (3.9.0 needed because cmake file install path changed)
-DEPEND=">=sys-devel/llvm-3.9.0"
+DEPEND=">=sys-devel/llvm-3.9.0[${MULTILIB_USEDEP}]"
S="${WORKDIR}/${MY_P}.src"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index b97b7d691f99..df6f7707c965 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -22,7 +22,7 @@ IUSE="debug +static-libs"
RDEPEND="!sys-libs/libunwind"
# llvm-config and cmake files needed to get proper flags
# (3.9.0 needed because cmake file install path changed)
-DEPEND=">=sys-devel/llvm-3.9.0"
+DEPEND=">=sys-devel/llvm-3.9.0[${MULTILIB_USEDEP}]"
multilib_src_configure() {
local libdir=$(get_libdir)