summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:52:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:30 +0100
commit8b849f37a4071a4ef2f2ed0b85556a1aa5dc9651 (patch)
tree8a6b44d8a9a9ecc64eb90a8eec436baa422d9ff4
parentdev-php/psr-log: bump to v1.1.2 (diff)
downloadgentoo-8b849f37a4071a4ef2f2ed0b85556a1aa5dc9651.tar.gz
gentoo-8b849f37a4071a4ef2f2ed0b85556a1aa5dc9651.tar.bz2
gentoo-8b849f37a4071a4ef2f2ed0b85556a1aa5dc9651.zip
dev-php/pecl-raphf: bump to v2.0.1
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-php/pecl-raphf/Manifest1
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-raphf/Manifest b/dev-php/pecl-raphf/Manifest
index 904c5c31024b..85a0d1db1563 100644
--- a/dev-php/pecl-raphf/Manifest
+++ b/dev-php/pecl-raphf/Manifest
@@ -1,2 +1,3 @@
DIST raphf-1.1.2.tgz 15915 BLAKE2B eb6135ab97b7842168c71fd037858c4e9f59573be89e8b4d4192f6cb94b73cb72f3d85fe2cbfe7d99a89c4e6a84480992db6103e969925c556d7790968f499d3 SHA512 dbde89a8ba508727ab2511b977b74fcc06010d75d043c2acca31e75cac2a105a8c322a01995271ab89fcd39d42a16b36c6d1c06a569e33926c0626d30a6672eb
DIST raphf-2.0.0.tgz 15715 BLAKE2B bab2997d9ce8358efaa69f2e633f49e4dd16f640e8d30284ebb33767285bead1aabcd973e7133152b82cf624e2c2e68cc6247e424aa5ed540e4211b5ed3da365 SHA512 16b029b694d30817a68a1a9d80bdf031d058ada45a93a4b34b49ec5d61fa8af78d0dbf1a3e5e2f1b950b2a11ac0b86b5a467807551556ab2a77f7f99739ed11b
+DIST raphf-2.0.1.tgz 16003 BLAKE2B 4eaf9f89e6572e17e0df347543dc99221f68d45103444f89e59862b9078574722278fbb1e2841b0a5952ffd6dfc4ea0fa81298f2014ffbe8a6b51ed6887f6692 SHA512 0a609fc21a62880963e7afb75297eb75a2598aab2c816cb61e84d665b0453e4952aa9bf25fe2c818cc94492a4b94aed965053c67899fdb984d88661364fffb1e
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild
new file mode 100644
index 000000000000..f28c7a6bb551
--- /dev/null
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="raphf"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-1 php7-2 php7-3"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable, persistent handle and resource factory API"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
+ php-ext-pecl-r3_src_install
+ fi
+}