summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-23 20:11:23 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-23 21:17:00 +0200
commit8bbbd40cd6bb5afd5a42bf26cc294bce39951fcb (patch)
treeadf99aff3fbf4a1c97f626034ab0545bcf4c6187
parentgames-arcade/penguin-command: Drop old (diff)
downloadgentoo-8bbbd40cd6bb5afd5a42bf26cc294bce39951fcb.tar.gz
gentoo-8bbbd40cd6bb5afd5a42bf26cc294bce39951fcb.tar.bz2
gentoo-8bbbd40cd6bb5afd5a42bf26cc294bce39951fcb.zip
games-arcade/pengupop: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch4
-rw-r--r--games-arcade/pengupop/pengupop-2.2.5-r1.ebuild55
2 files changed, 57 insertions, 2 deletions
diff --git a/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch b/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
index 5b6453accce7..fbbb704a6a30 100644
--- a/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
+++ b/games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
@@ -1,5 +1,5 @@
---- Makefile.am.old 2011-06-14 21:44:40.242317771 +0200
-+++ Makefile.am 2011-06-14 21:44:49.216882568 +0200
+--- a/Makefile.am.old 2011-06-14 21:44:40.242317771 +0200
++++ b/Makefile.am 2011-06-14 21:44:49.216882568 +0200
@@ -17,7 +17,7 @@
nodist_pengupop_SOURCES = images.h
diff --git a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..6938c534c5c9
--- /dev/null
+++ b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop gnome2-utils
+
+DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
+HOMEPAGE="http://freshmeat.net/projects/pengupop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-underlink.patch
+
+ sed -i \
+ -e '/Icon/s/\.png//' \
+ -e '/^Encoding/d' \
+ -e '/Categories/s/Application;//' \
+ pengupop.desktop || die
+
+ sed -i \
+ -e 's/-g -Wall -O2/-Wall/' \
+ Makefile.am || die
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ domenu pengupop.desktop
+ doicon -s 48 pengupop.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}