summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <m.seifert@digitalernachschub.de>2019-03-08 10:31:10 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-20 22:35:25 +0100
commit8cb524fa6aeff9d8115de47b9aef81d5c6c19a8a (patch)
tree2b908d41d88910e9f9e1721c5d68a9859a148a84
parentdev-python/cssutils: remove 1.0.2 (r0). (diff)
downloadgentoo-8cb524fa6aeff9d8115de47b9aef81d5c6c19a8a.tar.gz
gentoo-8cb524fa6aeff9d8115de47b9aef81d5c6c19a8a.tar.bz2
gentoo-8cb524fa6aeff9d8115de47b9aef81d5c6c19a8a.zip
dev-python/argon2_cffi: version bump to v19.1.0.
Closes: https://bugs.gentoo.org/679748 Signed-off-by: Michael Seifert <m.seifert@digitalernachschub.de> Closes: https://github.com/gentoo/gentoo/pull/11298 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/argon2_cffi/Manifest1
-rw-r--r--dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/argon2_cffi/Manifest b/dev-python/argon2_cffi/Manifest
index c1d9e9785d06..718c9b3bcd80 100644
--- a/dev-python/argon2_cffi/Manifest
+++ b/dev-python/argon2_cffi/Manifest
@@ -1 +1,2 @@
DIST argon2_cffi-18.3.0.tar.gz 1806363 BLAKE2B b60711ac929792ccd87a948f213288d4d47f45bf4bb52a1f6ac698d229e0953e37186c4e7d140231c205777be2fe31982a808cc676c13f12fe8602381665b74c SHA512 482a97ca17a23e4c1f93a0642e5aab1f2556d10f8a24d74afd051e6b58533c4767465abbfe8f1d39c150c5dbb191ad138d08e70633721753c7d317dbaf1cb375
+DIST argon2_cffi-19.1.0.tar.gz 1808120 BLAKE2B f30afe3c270fe4ff41ee97418a49480d7ec7235db659d033926cb7380afb664ab61cfb41fbae2f8581c6873c474746431a1360abc134244803acab73836ed533 SHA512 9bc10f0dfbb199e0ae0c9bd6a7c9183a5b0b108966d89bacf8ee744a926d400bccc14869b889a2482be4a5c48bd7ed0464cf316ecad74b758a5493beed7d466c
diff --git a/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild b/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild
new file mode 100644
index 000000000000..74c7ac49809d
--- /dev/null
+++ b/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2_cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+COMMON_DEPEND="
+ ~app-crypt/argon2-20171227:=
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst FAQ.rst README.rst )
+
+python_configure_all() {
+ export ARGON2_CFFI_USE_SYSTEM=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}