summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-12-03 15:53:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-12-03 16:23:38 +0000
commit8d3b87e999002b7df8dea6eb02c00e29b56aaeee (patch)
treed6c0a9683f965ce5bac721ee2d870d73189f74f4
parentnet-libs/rb_libtorrent: Change HOMEPAGE. Bug #567206 (diff)
downloadgentoo-8d3b87e999002b7df8dea6eb02c00e29b56aaeee.tar.gz
gentoo-8d3b87e999002b7df8dea6eb02c00e29b56aaeee.tar.bz2
gentoo-8d3b87e999002b7df8dea6eb02c00e29b56aaeee.zip
net-libs/rb_libtorrent: Version bump
Package-Manager: portage-2.2.26
-rw-r--r--net-libs/rb_libtorrent/Manifest1
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.7.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/Manifest b/net-libs/rb_libtorrent/Manifest
index caca87d79412..87ef05266a59 100644
--- a/net-libs/rb_libtorrent/Manifest
+++ b/net-libs/rb_libtorrent/Manifest
@@ -3,3 +3,4 @@ DIST libtorrent-rasterbar-0.16.19.tar.gz 3030253 SHA256 9ebd3fa8accfa27d0c81cdbb
DIST libtorrent-rasterbar-1.0.4.tar.gz 3297242 SHA256 1f567823133b1493b9717afc8334eed691bf0ab452d4a2e0f644989f13ce9db0 SHA512 1917d1207171d23dbcbbb17f0c3afdadcec059e8e603e2009bb72a610be598f2ff5a5ebdfc5a1b0e07563a05e774b395e24e04fabb17847b6a757f47f41a2313 WHIRLPOOL acbb9658d80f42bc6fe00cbe491e58bc059b6eeb96c0e34f7c86ad549104dabc4c9e2df5c931fd719f064bff6c4d06376022cf0e221034fc5e88af88d258f8f1
DIST libtorrent-rasterbar-1.0.5.tar.gz 3302804 SHA256 474a43da2147bec7e333c10f70b07221f4732dd67e071d5e90acc7edb8f657b0 SHA512 1ec54dfac1555ac1a843d12e239d781e940ef81ca13a943c58812b0fb62686e89bc5e0135feb94267fb624077cb0ad9971d496d8474b91f3687ef3b90a524df6 WHIRLPOOL a84f7895fdfda2020630c387eedd9b5a82ddc51af6b35fe8a2e7216495baaf9901a58ef2335c254fa3c2e0c713c7e6a1d9f976984fa5998329e47bc95ae22a63
DIST libtorrent-rasterbar-1.0.6.tar.gz 3307491 SHA256 c97de804b77f44591801631aca3869567671df2d3e2afe7f5453d8db2478fd61 SHA512 798529f877dc94aa8eb635677a2fffb6deead3937153e78ac5344fd81422f9fd9594e227db3ec0ae954dfc59e4dd5f3b8f6dbed2e3aa1f9a710c32b0622f54ee WHIRLPOOL 250651925c4d09b6e73c3c3e4b1e1f9131b49dbf3bdbeda3d683f204d4cebbcb865b694aa5e079072a73be922a25a2378094744bf4dd3bc4e220e9b0115342b6
+DIST libtorrent-rasterbar-1.0.7.tar.gz 3298005 SHA256 3e16e024b175fefada17471c659fdbcfab235f9619d4f0913faa13cb02ca8d83 SHA512 d60736af4b7c38317821810995dd9bec21688a9506e9b908394c2a1a87acd2abf23000856dedcad487b9ecc7b5680f83cfc09ff9db79af00fe21e94337daeacf WHIRLPOOL aff289e3ca85eedf688e8a898f0164a4d692e8c813b04dbae6323bc56003f5c3af862167a1d00a8bfe193dfda15d20a18a48bcbeac9313e29d6f2de35d20e621
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.7.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.7.ebuild
new file mode 100644
index 000000000000..938d680b9d5d
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib distutils-r1 versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+MY_PV=$(replace_all_version_separators '_' )
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/boost-1.53:=[threads]
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl:0= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-python.patch
+)
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules # bug 441842
+ --with-boost-libdir=/usr/$(get_libdir)
+ $(use_enable debug)
+ $(use_enable test tests)
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable python python-binding)
+ $(usex debug "--enable-logging=verbose" "")
+ )
+
+ use python && python_setup
+
+ autotools-utils_src_configure
+ use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${S}"/docs/. )
+
+ autotools-utils_src_install
+ use python && cd "${BUILD_DIR}"/bindings/python && distutils-r1_src_install
+}