summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-28 19:23:12 +0200
committerMichał Górny <mgorny@gentoo.org>2017-03-28 20:28:32 +0200
commit8d9081b80a3d1389a76eeb8db311bb0dea992c0b (patch)
tree206c8160c4e452259030aefba3d11adce3e95244
parentdev-python/axiom: Support combined dev-python/twisted (diff)
downloadgentoo-8d9081b80a3d1389a76eeb8db311bb0dea992c0b.tar.gz
gentoo-8d9081b80a3d1389a76eeb8db311bb0dea992c0b.tar.bz2
gentoo-8d9081b80a3d1389a76eeb8db311bb0dea992c0b.zip
dev-python/vertex: Support combined dev-python/twisted
-rw-r--r--dev-python/vertex/vertex-0.3.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/vertex/vertex-0.3.1-r1.ebuild b/dev-python/vertex/vertex-0.3.1-r1.ebuild
index 789b41a68876..066292c65488 100644
--- a/dev-python/vertex/vertex-0.3.1-r1.ebuild
+++ b/dev-python/vertex/vertex-0.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -18,9 +18,12 @@ RDEPEND="
libressl? ( dev-libs/libressl )
>=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
- dev-python/twisted-core[${PYTHON_USEDEP}]"
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )"
DEPEND="${RDEPEND}
- test? ( dev-python/pretend )"
+ test? ( dev-python/pretend[${PYTHON_USEDEP}] )"
python_install_all() {
distutils-r1_python_install_all