summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 13:23:54 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:20:56 +0200
commit8e412bc1ed2a21d52bce9aaf2864cf70627c6349 (patch)
tree2cf2f574be9e9a2a7b3752638c1eff97c8e63294
parentgames-board/gnome-chess: Drop old (diff)
downloadgentoo-8e412bc1ed2a21d52bce9aaf2864cf70627c6349.tar.gz
gentoo-8e412bc1ed2a21d52bce9aaf2864cf70627c6349.tar.bz2
gentoo-8e412bc1ed2a21d52bce9aaf2864cf70627c6349.zip
games-board/gnome-chess: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-3.20.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index f7cc4e4e106d..4f2feb75e19c 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-3.18.0.tar.xz 2779340 SHA256 c841198935d807618c3cecbf10ed24643390d504e17961717bac455f4e1b37ad SHA512 307ff5800792e231977288dedc7a04ccfbf74fc47de6263bacd19875a8092bef196eb97597fba975ff1f2a7fe9fcd802a3477a6099cf04e3ebcf4c7c94d0a094 WHIRLPOOL 0ad6868f7b27da1cbe0dbec8ee5facd0dc1189defbfbe3f2411dc23dedde3d3a09ef5eb8a59bd223ca973b1d141a28fa60323262a77f72c945089602fa5c0a40
+DIST gnome-chess-3.20.1.tar.xz 2789828 SHA256 4715349339491bd7a1072d5d362b5df76efa2067f4363c4b37d9579201d8c66d SHA512 c9238a7076ace27ed00ab47ade7383b24d6115a8cc5a174b1367dce90f7a19435ca135cf80ad45330d1dc0079846d43b9970bfd4382d41bdd5ada41d91193ac6 WHIRLPOOL acffb6bcdcff8763e1c884b902dd26302f9ae4086c7f15d4767076014cc18972807a4b71c3dec1f1fa73d82ae952982db39f0be58d0dbb5d47b9781a42ad4213
diff --git a/games-board/gnome-chess/gnome-chess-3.20.1.ebuild b/games-board/gnome-chess/gnome-chess-3.20.1.ebuild
new file mode 100644
index 000000000000..e3725edf5c1c
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.20.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 vala readme.gentoo-r1
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32:2
+ >=x11-libs/gtk+-3.19:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+ need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}