summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-26 17:01:35 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-26 17:01:52 +0100
commit8e4607e47bdd7d76671a3119a8ae0bcff598023b (patch)
treed8fbc97bab68b125d2ba5a9d6481fd34e2e6cf52
parentdev-lang/rakudo: Bump (diff)
downloadgentoo-8e4607e47bdd7d76671a3119a8ae0bcff598023b.tar.gz
gentoo-8e4607e47bdd7d76671a3119a8ae0bcff598023b.tar.bz2
gentoo-8e4607e47bdd7d76671a3119a8ae0bcff598023b.zip
net-libs/liboauth: Fix openssl-1.1 building
Thanks-to: Wataru Sakurai Thanks-to: Albert W. Hopkins Closes: https://bugs.gentoo.org/676080 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch22
-rw-r--r--net-libs/liboauth/liboauth-1.0.3-r1.ebuild3
2 files changed, 24 insertions, 1 deletions
diff --git a/net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch b/net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch
new file mode 100644
index 000000000000..c22a7753cce0
--- /dev/null
+++ b/net-libs/liboauth/files/liboauth-1.0.3-openssl-1.1_2.patch
@@ -0,0 +1,22 @@
+diff --git a/src/hash.c b/src/hash.c
+index 551991f..a0bc8b6 100644
+--- a/src/hash.c
++++ b/src/hash.c
+@@ -455,7 +455,7 @@ int oauth_verify_rsa_sha1 (const char *m, const char *c, const char *s) {
+ EVP_VerifyInit(md_ctx, EVP_sha1());
+ EVP_VerifyUpdate(md_ctx, m, strlen(m));
+ err = EVP_VerifyFinal(md_ctx, b64d, slen, pkey);
+- EVP_MD_CTX_cleanup(md_ctx);
++ EVP_MD_CTX_free(md_ctx);
+ EVP_PKEY_free(pkey);
+ xfree(b64d);
+ return (err);
+@@ -485,7 +485,7 @@ char *oauth_body_hash_file(char *filename) {
+ len=0;
+ md=(unsigned char*) xcalloc(EVP_MD_size(EVP_sha1()),sizeof(unsigned char));
+ EVP_DigestFinal(ctx, md,(unsigned int*) &len);
+- EVP_MD_CTX_cleanup(ctx);
++ EVP_MD_CTX_free(ctx);
+ return oauth_body_hash_encode(len, md);
+ }
+
diff --git a/net-libs/liboauth/liboauth-1.0.3-r1.ebuild b/net-libs/liboauth/liboauth-1.0.3-r1.ebuild
index 96cf577256ea..90acfdbc1fcc 100644
--- a/net-libs/liboauth/liboauth-1.0.3-r1.ebuild
+++ b/net-libs/liboauth/liboauth-1.0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,7 @@ REQUIRED_USE="bindist? ( nss )"
PATCHES=(
"${FILESDIR}"/${PN}-1.0.1-doxygen-out-of-tree.patch
"${FILESDIR}"/${PN}-1.0.3-openssl-1.1.patch
+ "${FILESDIR}"/${PN}-1.0.3-openssl-1.1_2.patch
)
CDEPEND="