summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-01 18:53:57 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-01 18:54:52 +0100
commit8e8942912a5967e7dfe24bdfd0c9ea470408505a (patch)
treed1b4184fdee368f6085bfbb2daca24a19c1fd677
parentnet-im/qtox: update dependencies and links in live ebuild (diff)
downloadgentoo-8e8942912a5967e7dfe24bdfd0c9ea470408505a.tar.gz
gentoo-8e8942912a5967e7dfe24bdfd0c9ea470408505a.tar.bz2
gentoo-8e8942912a5967e7dfe24bdfd0c9ea470408505a.zip
dev-ml/markup: bump to 0.7.3
Package-Manager: portage-2.3.2
-rw-r--r--dev-ml/markup/Manifest1
-rw-r--r--dev-ml/markup/markup-0.7.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/markup/Manifest b/dev-ml/markup/Manifest
index 558828892a02..1819e63ec676 100644
--- a/dev-ml/markup/Manifest
+++ b/dev-ml/markup/Manifest
@@ -1 +1,2 @@
DIST markup-0.7.2.tar.gz 275010 SHA256 630a737ab6113e17999aacfd55f73b6671211d7980be86f0c711c0b385887c34 SHA512 72a87f54692a0b751c23e6b52bc4ecaa68334b0c6c067793cbf5b011b7d06ce7563f9aa2daeef3553ab48bb6cb9e592587b5a4f37279eaef7b45e19e5b372f73 WHIRLPOOL 679a01c5d197eadf1a8b74247e276405c182acff4c7781b577fbad9fcdc33be164ff81222e79c4e0e5193d1295ee4896ddda547cce1712bfb5ebda050f5bf5ac
+DIST markup-0.7.3.tar.gz 275094 SHA256 e1eb3562e0d26ccc33aa5dbe802e4210dbd7c30a8e69b6098b825afb11bb6af1 SHA512 e4577e438241d58c728507c88f14b7f029dbc4aa6b9c5dbf78f03b6c083a430026158c3146a88c14c9cd90a242b1bb4ed838b150bb89433fb6a6f673e5d2bb66 WHIRLPOOL ad967738706d4c017f266ecdef7b0772ce0bc17f9bc7dda228ffabc9cccccc88cde69337e063577d1fcda1e93cf4a7f18bbbf09709ee82f0a4b8382f5e339d2e
diff --git a/dev-ml/markup/markup-0.7.3.ebuild b/dev-ml/markup/markup-0.7.3.ebuild
new file mode 100644
index 000000000000..59f9e4edfa52
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}p1"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt]
+ >=dev-ml/uutf-1.0:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}