summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-07 10:47:47 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-07 10:47:47 -0700
commit8ef416db9055a1f2aa8f1f8812936c66ba348628 (patch)
tree3436fc7fff5b132f74cf8ed312da8684f97b3163
parentdev-python/crcmod-1.7-r3: Add py38 (diff)
downloadgentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.tar.gz
gentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.tar.bz2
gentoo-8ef416db9055a1f2aa8f1f8812936c66ba348628.zip
dev-python/retry-decorator-1.1.1: bump, add py38, enable tests
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/retry-decorator/Manifest1
-rw-r--r--dev-python/retry-decorator/retry-decorator-1.1.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/retry-decorator/Manifest b/dev-python/retry-decorator/Manifest
index d371f3155f6b..072c511a6b63 100644
--- a/dev-python/retry-decorator/Manifest
+++ b/dev-python/retry-decorator/Manifest
@@ -1 +1,2 @@
DIST retry-decorator-1.0.0.tar.gz 2835 BLAKE2B b04d127ba3d357a61fb5e35a63867b297834acd82d0d7cdf736a69efe95fa33a263309799dcd4d8ae42e72ad5adb12b6c52557a81413ee8ebc49f5e0e728fa8b SHA512 f650740dd6d05010b7418b4d5ae7351058eb4418dabf7329390eaacceb72db60363bae8ff0bb15284301f0b5bfd9bfb731e71fdffb7231065a4db7ed6ce86da2
+DIST retry-decorator-1.1.1.tar.gz 4466 BLAKE2B a64836bba5620974e393a952544c82074b667a5fac80d6944069bf88e9162d03cc48cfe511f09476571c46561331576a2b06b2aefd087f905f968aa8257a596c SHA512 2241b24a02424905a2f3b7660c7ee4f6cd034c67c5019cce54d38ae250a9ac9e011fe323b25254bed051a0d3560d48ecdf4e2a1ee84cf2d7c5b1c12dea2921be
diff --git a/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild b/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild
new file mode 100644
index 000000000000..2903f122c5fb
--- /dev/null
+++ b/dev-python/retry-decorator/retry-decorator-1.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Decorator for retrying when exceptions occur"
+HOMEPAGE="https://github.com/pnpnpn/retry-decorator"
+SRC_URI="https://github.com/pnpnpn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest