summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-29 05:12:57 +0200
committerJeroen Roovers <jer@gentoo.org>2017-03-29 05:17:35 +0200
commit8f555cef8d2fba348176b9e16cab883a370f4225 (patch)
treeb8f608bc7ba155daa42c61a9a0aae06ab2e5d66c
parentx11-terms/rxvt-unicode: Drop USE=vanilla (bug #613724 by Alex Efros). (diff)
downloadgentoo-8f555cef8d2fba348176b9e16cab883a370f4225.tar.gz
gentoo-8f555cef8d2fba348176b9e16cab883a370f4225.tar.bz2
gentoo-8f555cef8d2fba348176b9e16cab883a370f4225.zip
x11-terms/rxvt-unicode: Update live ebuild.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild77
1 files changed, 16 insertions, 61 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
index 0c3f347b03e8..43645a40943a 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit autotools cvs eutils
DESCRIPTION="rxvt clone with xft and unicode support"
@@ -14,12 +14,10 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="
- 256-color alt-font-width blink buffer-on-clear +focused-urgency
- fading-colors +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
- startup-notification xft unicode3 +vanilla wcwidth
+ 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
+ pixbuf startup-notification xft unicode3
"
RESTRICT="test"
-REQUIRED_USE="vanilla? ( !alt-font-width !buffer-on-clear focused-urgency !secondary-wheel !wcwidth )"
RDEPEND="
media-libs/fontconfig
@@ -39,44 +37,19 @@ DEPEND="
"
S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+
+)
src_prepare() {
ecvs_clean
- # fix for prefix not installing properly
- epatch \
- "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch \
- "${FILESDIR}"/${PN}-9.21-xsubpp.patch
-
- if ! use vanilla; then
- ewarn "You are going to include unsupported third-party bug fixes/features."
- ewarn "If you want even more control over patches, then set USE=vanilla"
- ewarn "and store your patch set in /etc/portage/patches/${CATEGORY}/${PF}/"
-
- use wcwidth && epatch doc/wcwidth.patch
-
- # bug #240165
- use focused-urgency || epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
-
- # bug #263638
- epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
-
- # bug #237271
- epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
-
- # support for wheel scrolling on secondary screens
- use secondary-wheel && epatch "${FILESDIR}"/${PN}-9.19-secondary-wheel.patch
-
- # ctrl-l buffer fix
- use buffer-on-clear && epatch "${FILESDIR}"/${PN}-9.14-clear.patch
-
- use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
- fi
-
# kill the rxvt-unicode terminfo file - #192083
- sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die
- epatch_user
+ eapply_user
eautoreconf
}
@@ -86,26 +59,27 @@ src_configure() {
use iso14755 || myconf='--disable-iso14755'
+ # --enable-everything goes first: the order of the arguments matters
econf --enable-everything \
$(use_enable 256-color) \
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
$(use_enable font-styles) \
+ $(use_enable iso14755) \
$(use_enable mousewheel) \
$(use_enable perl) \
$(use_enable pixbuf) \
$(use_enable startup-notification) \
- $(use_enable xft) \
$(use_enable unicode3) \
- ${myconf}
+ $(use_enable xft)
}
src_compile() {
- emake || die "emake failed"
+ default
sed -i \
-e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
- "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+ "${S}"/doc/rxvt-tabbed || die
}
src_install() {
@@ -117,22 +91,3 @@ src_install() {
make_desktop_entry urxvt rxvt-unicode utilities-terminal \
"System;TerminalEmulator"
}
-
-pkg_postinst() {
- if use buffer-on-clear; then
- ewarn "You have enabled the buffer-on-clear USE flag."
- ewarn "Please note that, although this works well for most prompts,"
- ewarn "there have been cases with fancy prompts, like bug #397829,"
- ewarn "where it caused issues. Proceed with caution."
- ewarn " (keep this terminal open until you make sure it works)"
- fi
- if use secondary-wheel; then
- elog "You have enabled the secondary-wheel USE flag."
- elog "This allows you to scroll in secondary screens"
- elog "(like mutt's message list/view or nano) using the mouse wheel."
- elog
- elog "To actually enable the feature you have to add"
- elog " URxvt*secondaryWheel: true"
- elog "in your ~/.Xdefaults file"
- fi
-}