summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-30 21:21:47 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-30 21:24:03 +0200
commit8fb8d74e97bee32dd69071ffa0c03d5f5cebbc2a (patch)
tree4e1fb88678689855eaf3b71310fae43231a8dc4e
parentnet-analyzer/wireshark: Version bump. (diff)
downloadgentoo-8fb8d74e97bee32dd69071ffa0c03d5f5cebbc2a.tar.gz
gentoo-8fb8d74e97bee32dd69071ffa0c03d5f5cebbc2a.tar.bz2
gentoo-8fb8d74e97bee32dd69071ffa0c03d5f5cebbc2a.zip
dev-libs/libnl: Version bump.
Package-Manager: portage-2.3.0
-rw-r--r--dev-libs/libnl/Manifest1
-rw-r--r--dev-libs/libnl/libnl-3.2.28_rc1.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index ee5fcb1ab0a5..ea8a135180f9 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -1,2 +1,3 @@
DIST libnl-1.1.4.tar.gz 1174974 SHA256 4f80c21fe5bbcdde6e72b59b4f98306063a41421f909887c34e58d93e746d063 SHA512 25e26ddcc16540346ea34815ab6ac094177e5cee2eb3d843c4f8b30cd9d83390a3e87cb46046dc3bd9ae4d21f77e57bb3827c2cfc588eb18afe049921f2030b4 WHIRLPOOL eab5547dce7b11c86123fbcc9cd8e00100c7e78f48a4a9fef40f80f89407ea705b701f8f0eb7df63997866f17b0cf0924b43c69b29fa1f1b016fe997371b950e
DIST libnl-3.2.27.tar.gz 905330 SHA256 4bbbf92b3c78a90f423cf96260bf419a28b75db8cced47051217a56795f58ec6 SHA512 f66d1c42eef75f6a1008abd6850f00abb0290d49bb685b4df43464c4dbf57d68fd4551f2a77bb2f375fd0a342b73cfd54d17c791f01ea43ce02683c8703e3a33 WHIRLPOOL 0bf32ca28b1f858caf99cb633ae4c3b863e53f8cb4b3b1703b454117e2eea2563d34b08c4ac920afb63e45c4717ba7628730a428df76f56818fe10cf336c4185
+DIST libnl-3.2.28-rc1.tar.gz 942021 SHA256 ef1ca7558d8426b53ebc090c19c53f3feb78d7e6a78bfc0f0ea1561ea4642357 SHA512 1897ca9de7ce9652bee7fcce1c2cb037a5394f11e3d5a82bbe3af036ad0d9339c4b8ca293f0fddb44b5facb69c379818a48d40c7b36ef1be43be906eb2f9a553 WHIRLPOOL d12d98172e79b7e1ee09c95233aca8d2af0781b51eecd218e8f09eaebd173606b3680a4dd752caead078e738a5457a4e77feed89b47c265c2f67e5b8c06c67af
diff --git a/dev-libs/libnl/libnl-3.2.28_rc1.ebuild b/dev-libs/libnl/libnl-3.2.28_rc1.ebuild
new file mode 100644
index 000000000000..b592205c21fc
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.28_rc1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1 eutils libtool multilib multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="A collection of libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+SRC_URI="
+ https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz
+"
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="static-libs python utils"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ sys-devel/flex
+ sys-devel/bison
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( ChangeLog )
+
+S=${WORKDIR}/${LIBNL_P}
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+ "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
+ "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+
+ # out-of-source build broken
+ # https://github.com/thom311/libnl/pull/58
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils cli)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+ cd python || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}