summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-08 22:35:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 23:16:45 +0100
commit8fbc78adda521381c3f87d7da4c9d4dc7a674647 (patch)
treef1337f93a89d2b6f627f2445dacdff49319fbdd6
parentsci-biology/piler: Modernise to EAPI 6 (diff)
downloadgentoo-8fbc78adda521381c3f87d7da4c9d4dc7a674647.tar.gz
gentoo-8fbc78adda521381c3f87d7da4c9d4dc7a674647.tar.bz2
gentoo-8fbc78adda521381c3f87d7da4c9d4dc7a674647.zip
sci-biology/pilercr: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4165
-rw-r--r--sci-biology/pilercr/files/pilercr-1.0-fix-build-system.patch34
-rw-r--r--sci-biology/pilercr/pilercr-1.0-r1.ebuild30
-rw-r--r--sci-biology/pilercr/pilercr-1.0.ebuild30
3 files changed, 64 insertions, 30 deletions
diff --git a/sci-biology/pilercr/files/pilercr-1.0-fix-build-system.patch b/sci-biology/pilercr/files/pilercr-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..3754f80a9346
--- /dev/null
+++ b/sci-biology/pilercr/files/pilercr-1.0-fix-build-system.patch
@@ -0,0 +1,34 @@
+Make build system honour user variables
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,4 @@
+-CFLAGS = -O3 -funroll-loops -Winline -DNDEBUG=1
+-#CFLAGS = -O3 -funroll-loops -Winline
+-LDLIBS = -lm -static
+-# LDLIBS = -lm
++LDLIBS = -lm
+
+ OBJ = .o
+ EXE =
+@@ -9,17 +6,13 @@
+ RM = rm -f
+ CP = cp
+
+-GPP = g++
+-LD = $(GPP) $(CFLAGS)
+-CPP = $(GPP) -c $(CFLAGS)
+-
+ all: pilercr
+
+ CPPSRC = $(sort $(wildcard *.cpp))
+ CPPOBJ = $(subst .cpp,.o,$(CPPSRC))
+
+-$(CPPOBJ): %.o: %.cpp
+- $(CPP) $< -o $@
++%.o: %.cpp
++ $(CXX) $(CXXFLAGS) -DNDEBUG $(CPPFLAGS) -c $< -o $@
+
+ pilercr: $(CPPOBJ)
+- $(LD) -o pilercr $(CPPOBJ) $(LDLIBS)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o pilercr $(CPPOBJ) $(LDLIBS)
diff --git a/sci-biology/pilercr/pilercr-1.0-r1.ebuild b/sci-biology/pilercr/pilercr-1.0-r1.ebuild
new file mode 100644
index 000000000000..8b1abd5de7d7
--- /dev/null
+++ b/sci-biology/pilercr/pilercr-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analysis of Clustered Regularly Interspaced Short Palindromic Repeats (CRISPRs)"
+HOMEPAGE="http://www.drive5.com/pilercr/"
+SRC_URI="http://www.drive5.com/pilercr/pilercr1.06.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.0-gcc43.patch
+)
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/sci-biology/pilercr/pilercr-1.0.ebuild b/sci-biology/pilercr/pilercr-1.0.ebuild
deleted file mode 100644
index ae34e105c641..000000000000
--- a/sci-biology/pilercr/pilercr-1.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Analysis of Clustered Regularly Interspaced Short Palindromic Repeats (CRISPRs)"
-HOMEPAGE="http://www.drive5.com/pilercr/"
-#SRC_URI="http://www.drive5.com/pilercr/pilercr.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-S="${WORKDIR}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- emake GPP="$(tc-getCXX)" CFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
-}