summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 19:08:12 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 19:08:29 +0200
commit8ff8ef49e0509d89d2b0ae078ae29e458aa9e4c7 (patch)
tree6e24cce994462d124959ced710c551a3449b3fdb
parentdev-libs/vrb: Clean up old. (diff)
downloadgentoo-8ff8ef49e0509d89d2b0ae078ae29e458aa9e4c7.tar.gz
gentoo-8ff8ef49e0509d89d2b0ae078ae29e458aa9e4c7.tar.bz2
gentoo-8ff8ef49e0509d89d2b0ae078ae29e458aa9e4c7.zip
sys-devel/llvm: make 3.4.2 work post-Prefix bootstrap too
Package-Manager: portage-2.2.28
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index 0f5e951dbdcd..cd3155f40bb6 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -190,6 +190,10 @@ src_install() {
if ! use clang; then
rm "${WORKDIR}"/${PN}-3.4-manpages/clang.1 || die
+ else
+ for tool in clang{,++}{,-${PV}} ; do
+ dosym /usr/bin/${tool} /usr/bin/${CHOST}-${tool}
+ done
fi
doman "${WORKDIR}"/${PN}-3.4-manpages/*.1
@@ -200,7 +204,7 @@ src_install() {
eval $(grep PACKAGE_VERSION= configure)
[[ -n ${PACKAGE_VERSION} ]] && libpv=${PACKAGE_VERSION}
libpvminor=${libpv%.[0-9]*}
- for lib in lib{EnhancedDisassembly,LLVM-${libpv},LTO,profile_rt,clang}.dylib LLVMHello.dylib clang/${libpv}/lib/darwin/libclang_rt.asan_{osx,iossim}_dynamic.dylib; do
+ for lib in lib{EnhancedDisassembly,LLVM-${libpv},LTO,profile_rt,clang}.dylib LLVMHello.dylib BugpointPasses.dylib clang/${libpv}/lib/darwin/libclang_rt.asan_{osx,iossim}_dynamic.dylib; do
# libEnhancedDisassembly is Darwin10 only, so non-fatal
# + omit clang libs if not enabled
[[ -f ${ED}/usr/lib/${lib} ]] || continue