summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-01-16 21:44:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-01-16 21:44:04 +0700
commit908d8e520d6078a592ce8db946e86f9e26a8bbdc (patch)
tree685ca351347596b29fd14858cb213b7e28bc3b22
parentsys-kernel/gentoo-sources: amd64 stable wrt bug #644662 (diff)
downloadgentoo-908d8e520d6078a592ce8db946e86f9e26a8bbdc.tar.gz
gentoo-908d8e520d6078a592ce8db946e86f9e26a8bbdc.tar.bz2
gentoo-908d8e520d6078a592ce8db946e86f9e26a8bbdc.zip
dev-python/matplotlib: in python3-only setup, don't pull python2 packages in
Suggested-by: jan vereecke <vereecke.jan@skynet.be> Closws: https://bugs.gentoo.org/642090 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild b/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
index 37e6b936a7e4..f50fb4db1178 100644
--- a/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
@@ -34,18 +34,19 @@ REQUIRED_USE="
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
+PY2_DEPEND="
+ $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)"
COMMON_DEPEND="
dev-python/cycler[${PYTHON_USEDEP}]
- dev-python/functools32[${PY2_USEDEP}]
>=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
- dev-python/subprocess32[${PY2_USEDEP}]
media-fonts/stix-fonts
media-libs/freetype:2
media-libs/libpng:0
- python_targets_python2_7? ( dev-python/backports-functools-lru-cache[${PY2_USEDEP}] )
>=media-libs/qhull-2013
cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
gtk2? (
@@ -59,6 +60,7 @@ COMMON_DEPEND="
# dev-python/pycxx
DEPEND="${COMMON_DEPEND}
+ ${PY2_DEPEND}
dev-python/versioneer[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
@@ -82,6 +84,7 @@ DEPEND="${COMMON_DEPEND}
)"
RDEPEND="${COMMON_DEPEND}
+ ${PY2_DEPEND}
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
gtk3? (