summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-08-05 14:15:22 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-08-05 14:15:22 -0700
commit90938bfdf79a99184d64f004acaf30f69afe1a12 (patch)
tree595686cfe4da663e805c497e5686a538f8defe65
parentdev-haskell/hps: tweak for ghc-8.8 (diff)
downloadgentoo-90938bfdf79a99184d64f004acaf30f69afe1a12.tar.gz
gentoo-90938bfdf79a99184d64f004acaf30f69afe1a12.tar.bz2
gentoo-90938bfdf79a99184d64f004acaf30f69afe1a12.zip
net-proxy/miniproxuy: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--net-proxy/microsocks/Manifest1
-rw-r--r--net-proxy/microsocks/files/microsocks.confd4
-rw-r--r--net-proxy/microsocks/files/microsocks.initd14
-rw-r--r--net-proxy/microsocks/metadata.xml8
-rw-r--r--net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild32
5 files changed, 59 insertions, 0 deletions
diff --git a/net-proxy/microsocks/Manifest b/net-proxy/microsocks/Manifest
new file mode 100644
index 000000000000..db62609b7471
--- /dev/null
+++ b/net-proxy/microsocks/Manifest
@@ -0,0 +1 @@
+DIST microsocks-1.0.1_p20200805.tar.gz 9119 BLAKE2B e998dcb6f109e6bdfd8580ae316e3d61cba0a47b42206bf7482821a06f4fa3b4c56a42fae3948783d2a99bc70f8b60603699a1afba215b45fafe509396c59ec9 SHA512 966df1d654e0eb759f3aca9988dc9f28fa105c3c8586c3e221e3ebdd6f750cb0f1e2d3f544367e5b469203bfe372e9e8451eac8187408bc1618d68dd00236175
diff --git a/net-proxy/microsocks/files/microsocks.confd b/net-proxy/microsocks/files/microsocks.confd
new file mode 100644
index 000000000000..1c9387fb09c3
--- /dev/null
+++ b/net-proxy/microsocks/files/microsocks.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/microsocks - config for microsocks
+#
+# see README.md or --help for possible parameters
+microsocks_args=""
diff --git a/net-proxy/microsocks/files/microsocks.initd b/net-proxy/microsocks/files/microsocks.initd
new file mode 100644
index 000000000000..a520e94920cc
--- /dev/null
+++ b/net-proxy/microsocks/files/microsocks.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="microsocks daemon"
+description="Multithreaded, small, efficient SOCKS5 server"
+pidfile="/run/${RC_SVCNAME}.pid"
+command=/usr/bin/microsocks
+command_args="${microsocks_args}"
+command_background=1
+
+depend() {
+ need net
+}
diff --git a/net-proxy/microsocks/metadata.xml b/net-proxy/microsocks/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/net-proxy/microsocks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild b/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild
new file mode 100644
index 000000000000..ed8fd541226f
--- /dev/null
+++ b/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT_HASH="de2d746862e1ec78688500955e15706f173a1151"
+DESCRIPTION="Multithreaded, small, efficient SOCKS5 server"
+HOMEPAGE="https://github.com/rofl0r/microsocks"
+SRC_URI="https://github.com/rofl0r/microsocks/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -r -e 's:/usr/local:/usr:' -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}