summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2020-10-06 06:54:16 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2020-10-06 07:06:22 +0200
commit9113629329830be0555256257ffdbc340cb934bf (patch)
treee51879352776ed538416a07a894b2f35a33125c8
parentdev-util/docker-ls: Keyword 0.3.1 arm64, #741676 (diff)
downloadgentoo-9113629329830be0555256257ffdbc340cb934bf.tar.gz
gentoo-9113629329830be0555256257ffdbc340cb934bf.tar.bz2
gentoo-9113629329830be0555256257ffdbc340cb934bf.zip
dev-util/dwarves: Switch from eclass cmake-utils to cmake
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
-rw-r--r--dev-util/dwarves/dwarves-1.17-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.17-r1.ebuild b/dev-util/dwarves/dwarves-1.17-r1.ebuild
new file mode 100644
index 000000000000..063b96dc5e59
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.17-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit multilib cmake python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake_src_install
+}