summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-08-04 10:35:21 +0100
committerAmy Liffey <amynka@gentoo.org>2018-08-04 10:37:35 +0100
commit91c24d2c4cddfcdafa9c7e8f7d4722ce7c04e8ac (patch)
tree59f7d652714d449b76db3b5e4c01643f8e0abfe1
parentapp-xemacs/cc-mode: version bump (diff)
downloadgentoo-91c24d2c4cddfcdafa9c7e8f7d4722ce7c04e8ac.tar.gz
gentoo-91c24d2c4cddfcdafa9c7e8f7d4722ce7c04e8ac.tar.bz2
gentoo-91c24d2c4cddfcdafa9c7e8f7d4722ce7c04e8ac.zip
sci-geosciences/mapnik: version bump 3.0.18
Suggested-by: LW <g2du-mail@duboulder.com> Closes: https://bugs.gentoo.org/659312 Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--sci-geosciences/mapnik/Manifest1
-rw-r--r--sci-geosciences/mapnik/files/mapnik-3.0.18-scons.patch39
-rw-r--r--sci-geosciences/mapnik/mapnik-3.0.18.ebuild117
-rw-r--r--sci-geosciences/mapnik/metadata.xml1
4 files changed, 158 insertions, 0 deletions
diff --git a/sci-geosciences/mapnik/Manifest b/sci-geosciences/mapnik/Manifest
index b887a1cf8457..814739a065bd 100644
--- a/sci-geosciences/mapnik/Manifest
+++ b/sci-geosciences/mapnik/Manifest
@@ -1 +1,2 @@
+DIST mapnik-3.0.18.tar.bz2 10103474 BLAKE2B de914ffe31940b74114cdf07a9ff13f36c7210d27b84cecd16fda7c429f0c4be7ffb9e677cf1bc8d156298b5f10ed2a41adcbf4f7727bbf85d2f0099950f5c4f SHA512 7af04b9437c83cddedf2b43f7da0622e44178b4ecce80c0349bacf551bf747698d9ec9e4d6eee68c0265feeae5833281215a759de5a1394abbdfdd39eef39661
DIST mapnik-3.0.9.tar.gz 13434729 BLAKE2B 49cf90089b34cfc706f85950d090609d5f9a5a6e9cfb56f6e1f1a6279f864b35f3f8d456caa2365787261affc4acb85ad93621d6471efed85f560c808dc0535a SHA512 ad45ecbb2661e860b7057e0a235542a390ae5790f401ef2c04f1517b6487e83cdb8e307072681847cb72a3abc242e0114bc15d48f504dec1f92df970dd1556e1
diff --git a/sci-geosciences/mapnik/files/mapnik-3.0.18-scons.patch b/sci-geosciences/mapnik/files/mapnik-3.0.18-scons.patch
new file mode 100644
index 000000000000..2414bf95fedd
--- /dev/null
+++ b/sci-geosciences/mapnik/files/mapnik-3.0.18-scons.patch
@@ -0,0 +1,39 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -317,7 +317,7 @@
+ ('LINK_PRIORITY','Priority list in which to sort library and include paths (default order is internal, other, frameworks, user, then system - see source of `sort_paths` function for more detail)',','.join(DEFAULT_LINK_PRIORITY)),
+
+ # Install Variables
+- ('PREFIX', 'The install path "prefix"', '/usr/local'),
++ ('PREFIX', 'The install path "prefix"', '/usr'),
+ ('LIBDIR_SCHEMA', 'The library sub-directory appended to the "prefix", sometimes lib64 on 64bit linux systems', LIBDIR_SCHEMA_DEFAULT),
+ ('DESTDIR', 'The root directory to install into. Useful mainly for binary package building', '/'),
+ ('PATH', 'A custom path (or multiple paths divided by ":") to append to the $PATH env to prioritize usage of command line programs (if multiple are present on the system)', ''),
+@@ -1222,6 +1222,8 @@
+
+ color_print(4,'Configuring build environment...')
+
++ OPTIONAL_LIBSHEADERS = []
++
+ if not env['FAST']:
+ SetCacheMode('force')
+
+@@ -1410,7 +1412,8 @@
+ # https://github.com/mapnik/mapnik/issues/913
+ if env.get('XMLPARSER') and env['XMLPARSER'] == 'libxml2':
+ if env.get('XML2_LIBS') or env.get('XML2_INCLUDES'):
+- OPTIONAL_LIBSHEADERS.insert(0,['libxml2','libxml/parser.h',True,'C'])
++ # code doesn't actually use HAVE_XMML2 but set just to have a fifth value
++ OPTIONAL_LIBSHEADERS.append(['libxml2','libxml/parser.h',True,'C','-DHAVE_XML2'])
+ if env.get('XML2_INCLUDES'):
+ inc_path = env['XML2_INCLUDES']
+ env.AppendUnique(CPPPATH = fix_path(inc_path))
+@@ -1428,8 +1431,6 @@
+ else:
+ env['SKIPPED_DEPS'].extend(['dlfcn'])
+
+- OPTIONAL_LIBSHEADERS = []
+-
+ if env['JPEG']:
+ OPTIONAL_LIBSHEADERS.append(['jpeg', ['stdio.h', 'jpeglib.h'], False,'C','-DHAVE_JPEG'])
+ inc_path = env['%s_INCLUDES' % 'JPEG']
diff --git a/sci-geosciences/mapnik/mapnik-3.0.18.ebuild b/sci-geosciences/mapnik/mapnik-3.0.18.ebuild
new file mode 100644
index 000000000000..46c348fc71ea
--- /dev/null
+++ b/sci-geosciences/mapnik/mapnik-3.0.18.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils scons-utils toolchain-funcs
+
+DESCRIPTION="A Free Toolkit for developing mapping applications"
+HOMEPAGE="http://www.mapnik.org/"
+SRC_URI="https://github.com/mapnik/mapnik/releases/download/v${PV}/mapnik-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/mapnik-v${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo debug doc gdal osmfonts postgres sqlite"
+
+RDEPEND="
+ >=dev-libs/boost-1.48[threads]
+ dev-libs/icu:=
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/harfbuzz
+ dev-libs/libxml2
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ virtual/jpeg:0=
+ media-libs/libwebp
+ sci-libs/proj
+ media-fonts/dejavu
+ x11-libs/agg[truetype]
+ cairo? (
+ x11-libs/cairo
+ dev-cpp/cairomm
+ )
+ osmfonts? (
+ media-fonts/dejavu
+ media-fonts/noto
+ media-fonts/noto-cjk
+ media-fonts/unifont
+ )
+ postgres? ( >=dev-db/postgresql-8.3:* )
+ gdal? ( sci-libs/gdal )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-configure-only-once.patch"
+ "${FILESDIR}/${PN}-2.2.0-dont-run-ldconfig.patch"
+ "${FILESDIR}/${PN}-3.0.18-scons.patch"
+)
+
+src_prepare() {
+ default
+
+ # do not version epidoc data
+ sed -i \
+ -e 's:-`mapnik-config --version`::g' \
+ utils/epydoc_config/build_epydoc.sh || die
+
+ # force user flags, optimization level
+ sed -i -e "s:\-O%s:%s:" \
+ -i -e "s:env\['OPTIMIZATION'\]:'${CXXFLAGS}':" \
+ SConstruct || die
+}
+
+src_configure() {
+# local PYTHONCMD="$(which python2.7)"
+ local PLUGINS=shape,csv,raster,geojson
+ use gdal && PLUGINS+=,gdal,ogr
+ use postgres && PLUGINS+=,postgis
+ use sqlite && PLUGINS+=,sqlite
+
+ MYSCONS=(
+ "CC=$(tc-getCC)"
+ "CXX=$(tc-getCXX)"
+ "INPUT_PLUGINS=${PLUGINS}"
+ "PREFIX=/usr"
+ "DESTDIR=${D}"
+ "XMLPARSER=libxml2"
+ "LINKING=shared"
+ "RUNTIME_LINK=shared"
+ "PROJ_INCLUDES=/usr/include"
+ "PROJ_LIBS=/usr/$(get_libdir)"
+ "LIBDIR_SCHEMA=$(get_libdir)"
+ "FREETYPE_INCLUDES=/usr/include/freetype2"
+ "FREETYPE_LIBS=/usr/$(get_libdir)"
+ "XML2_INCLUDES=/usr/include/libxml2"
+ "XML2_LIBS=/usr/$(get_libdir)"
+ "SYSTEM_FONTS=/usr/share/fonts"
+ CAIRO="$(usex cairo 1 0)"
+ DEBUG="$(usex debug 1 0)"
+ XML_DEBUG="$(usex debug 1 0)"
+ DEMO="$(usex doc 1 0)"
+ SAMPLE_INPUT_PLUGINS="$(usex doc 1 0)"
+ "CUSTOM_LDFLAGS=${LDFLAGS}"
+ "CUSTOM_LDFLAGS+=-L${ED}/usr/$(get_libdir)"
+ )
+ escons "${MYSCONS[@]}" configure
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ escons "${MYSCONS[@]}" DESTDIR="${D}" install
+
+ dodoc AUTHORS.md README.md CHANGELOG.md
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See the home page or wiki (https://github.com/mapnik/mapnik/wiki) for more info"
+ elog "or the installed examples for the default mapnik ogcserver config."
+ elog ""
+}
diff --git a/sci-geosciences/mapnik/metadata.xml b/sci-geosciences/mapnik/metadata.xml
index bbbaaa7e4d1d..7f8d2fd981b3 100644
--- a/sci-geosciences/mapnik/metadata.xml
+++ b/sci-geosciences/mapnik/metadata.xml
@@ -11,6 +11,7 @@
</longdescription>
<use>
<flag name="gdal">Enable <pkg>sci-libs/gdal</pkg> library support</flag>
+ <flag name="osmfonts">Enable openstreetmaps font styles</flag>
</use>
<upstream>
<remote-id type="github">downloads/mapnik</remote-id>