summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-11-22 11:27:20 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-11-22 18:38:35 +0800
commit91d79eef681701c50bc9b1cc3b8b43940ab4eb4e (patch)
treef1224bdb577c14cf1edf9113a3d018597b6566a0
parentdev-db/tora: Fix DEPEND (diff)
downloadgentoo-91d79eef681701c50bc9b1cc3b8b43940ab4eb4e.tar.gz
gentoo-91d79eef681701c50bc9b1cc3b8b43940ab4eb4e.tar.bz2
gentoo-91d79eef681701c50bc9b1cc3b8b43940ab4eb4e.zip
sys-libs/glibc: 2.19 recognize gcc-10 as a sane compiler.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sys-libs/glibc/files/2.19/glibc-2.19-gcc-10.patch15
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild1
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/2.19/glibc-2.19-gcc-10.patch b/sys-libs/glibc/files/2.19/glibc-2.19-gcc-10.patch
new file mode 100644
index 000000000000..45e8ab80007e
--- /dev/null
+++ b/sys-libs/glibc/files/2.19/glibc-2.19-gcc-10.patch
@@ -0,0 +1,15 @@
+Identify gcc-10+ as a good compiler.
+
+Index: work/glibc-2.19/configure
+===================================================================
+--- glibc-2.19/configure
++++ glibc-2.19/configure
+@@ -4710,7 +4710,7 @@ $as_echo_n "checking version of $CC... "
+ ac_prog_version=`$CC -v 2>&1 | sed -n 's/^.*version \([egcygnustpi-]*[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 4.[4-9].* | 4.[1-9][0-9].* | [5-9].* )
++ 4.[4-9].* | 4.[1-9][0-9].* | [5-9].* | [1-9][0-9].* )
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 3b45b557922d..47ae2c50d61a 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -717,6 +717,7 @@ src_prepare() {
eapply "${FILESDIR}"/2.19/glibc-2.19-kernel-2.6.16-compat.patch
eapply "${FILESDIR}"/2.19/glibc-2.19-kernel-2.6.16-hide-pipe2.patch
+ eapply "${FILESDIR}"/2.19/glibc-2.19-gcc-10.patch
cd "${WORKDIR}"
find . -name configure -exec touch {} +