summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-23 10:53:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-23 10:54:57 +0200
commit9219ff7e9396b135e14e2d3c8152af1fe04a80d0 (patch)
treeb9b86078ab6d54047ce7c979c22af52245b0d65e
parentdev-vcs/git: Bump to version 2.14.3 (diff)
downloadgentoo-9219ff7e9396b135e14e2d3c8152af1fe04a80d0.tar.gz
gentoo-9219ff7e9396b135e14e2d3c8152af1fe04a80d0.tar.bz2
gentoo-9219ff7e9396b135e14e2d3c8152af1fe04a80d0.zip
dev-libs/apr: Bump to version 1.6.3
Package-Manager: Portage-2.3.12, Repoman-2.3.3
-rw-r--r--dev-libs/apr/Manifest1
-rw-r--r--dev-libs/apr/apr-1.6.3.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/dev-libs/apr/Manifest b/dev-libs/apr/Manifest
index a71e04f592d0..144b1c63d82f 100644
--- a/dev-libs/apr/Manifest
+++ b/dev-libs/apr/Manifest
@@ -1,2 +1,3 @@
DIST apr-1.5.2.tar.bz2 826885 SHA256 7d03ed29c22a7152be45b8e50431063736df9e1daa1ddf93f6a547ba7a28f67a SHA512 d1156ad16abf07887797777b56c2147c890f16d8445829b3e3b4917950d24c5fd2f8febd439992467a5ea0511da562c0fb4a7cfd8a235ab55882388bfa2b919d WHIRLPOOL 3f6fbb9410f7cd3ace2f80f361a02b190e14d744f38dbd6f87a5c60b4b1c4a99cd902ba9351a235d9f3bab044a981de21fb6c193d3ab3caba2448bf6c4e1bd1b
DIST apr-1.6.2.tar.bz2 853363 SHA256 09109cea377bab0028bba19a92b5b0e89603df9eab05c0f7dbd4dd83d48dcebd SHA512 20f449fde522f186b919b64ce6f90073b267557e17438607d31af917eca7941222dd7a7379d66f1430ff68f7e28fbccd140d24f3ca7aae8a876a550b19de284a WHIRLPOOL 4fd43497ed091f9da2a8c8a57017344dc7492b18793e8a16eae480ddbba8f18ebc66925418d8b5fa8fa6fa023b59a482d62c8ba1ee49a575aa6f7918b703ea30
+DIST apr-1.6.3.tar.bz2 854100 SHA256 131f06d16d7aabd097fa992a33eec2b6af3962f93e6d570a9bd4d85e95993172 SHA512 f6b8679ae7fafff793c825c78775c84a646267c441710a50664589850e13148719b4eab48ab6e7c95b7aed085cff831115687434a7b160dcc2faa0eae63ac996 WHIRLPOOL b17edd2b8fed082f8e25e56728fec3d3629debdb7bcc78dab94aa6665371a97ece5b321d37caf717106abd03740b5724108364553106055ce7fa7c9b50a196ed
diff --git a/dev-libs/apr/apr-1.6.3.ebuild b/dev-libs/apr/apr-1.6.3.ebuild
new file mode 100644
index 000000000000..cc08f2934308
--- /dev/null
+++ b/dev-libs/apr/apr-1.6.3.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool ltprune multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="https://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility selinux static-libs +urandom"
+
+CDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
+ elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-apache )"
+DEPEND="${CDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )"
+
+DOCS=( CHANGES NOTICE README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-mint.patch
+ "${FILESDIR}"/${PN}-1.5.0-libtool.patch
+ "${FILESDIR}"/${PN}-1.5.0-cross-types.patch
+ "${FILESDIR}"/${PN}-1.5.0-sysroot.patch #385775
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ eapply "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf=(
+ --enable-layout=gentoo
+ --enable-nonportable-atomics
+ --enable-posix-shm
+ --enable-threads
+ $(use_enable static-libs static)
+ )
+
+ [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+ if tc-is-cross-compiler; then
+ # The apache project relies heavily on AC_TRY_RUN and doesn't
+ # have any sane cross-compiling fallback logic.
+ export \
+ ac_cv_file__dev_zero="yes" \
+ ac_cv_func_sem_open="yes" \
+ ac_cv_negative_eai="yes" \
+ ac_cv_o_nonblock_inherited="no" \
+ ac_cv_struct_rlimit="yes" \
+ ap_cv_atomic_builtins="yes" \
+ apr_cv_accept4="yes" \
+ apr_cv_dup3="yes" \
+ apr_cv_epoll="yes" \
+ apr_cv_epoll_create1="yes" \
+ apr_cv_gai_addrconfig="yes" \
+ apr_cv_mutex_recursive="yes" \
+ apr_cv_mutex_robust_shared="yes" \
+ apr_cv_process_shared_works="yes" \
+ apr_cv_pthreads_lib="-pthread" \
+ apr_cv_sock_cloexec="yes" \
+ apr_cv_tcp_nodelay_with_cork="yes"
+ fi
+
+ if use urandom; then
+ myconf+=( --with-devrandom=/dev/urandom )
+ elif (( ${CHOST#*-hpux11.} <= 11 )); then
+ : # no /dev/*random on hpux11.11 and before, $PN detects this.
+ else
+ myconf+=( --with-devrandom=/dev/random )
+ fi
+
+ tc-is-static-only && myconf+=( --disable-dso )
+
+ # shl_load does not search runpath, but hpux11 supports dlopen
+ [[ ${CHOST} == *-hpux11* ]] && myconf+=( --enable-dso=dlfcn )
+
+ if [[ ${CHOST} == *-solaris2.10 ]]; then
+ case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
+ *atomic_cas_ptr*) ;;
+ *)
+ elog "You do not have Solaris Patch ID "$(
+ [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
+ )" (Problem 4954703) installed on your host ($(hostname)),"
+ elog "using generic atomic operations instead."
+ myconf+=( --disable-nonportable-atomics )
+ ;;
+ esac
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ # This header is the same across targets, so use the build compiler.
+ emake tools/gen_test_char
+ tc-export_build_env BUILD_CC
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+ tools/gen_test_char.c -o tools/gen_test_char || die
+ fi
+
+ emake
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ # Prallel install breaks since apr-1.5.1
+ #make -j1 DESTDIR="${D}" install || die
+
+ prune_libtool_files --all
+
+ if use doc; then
+ docinto html
+ dodoc -r docs/dox/html/*
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ # Even in Prefix, we don't need this on AIX.
+ rm -f "${ED%/}/usr/$(get_libdir)/apr.exp"
+}