summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-25 18:37:20 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-25 18:37:20 +0100
commit922290d4950d8c2be8d43dc010ba0a1571207fd2 (patch)
tree0b76339d26c6299340a7a4d3674a2c34f22fdc2f
parentkde-misc/markdownpart: Stabilize 0.1.1 arm64, #753242 (diff)
downloadgentoo-922290d4950d8c2be8d43dc010ba0a1571207fd2.tar.gz
gentoo-922290d4950d8c2be8d43dc010ba0a1571207fd2.tar.bz2
gentoo-922290d4950d8c2be8d43dc010ba0a1571207fd2.zip
net-dns/https_dns_proxy: fix automagic gtest dep
* Tests are not ready yet Closes: https://github.com/gentoo/gentoo/pull/18296 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild15
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild15
2 files changed, 24 insertions, 6 deletions
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
index c7003379c001..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${WORKDIR}/${P}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
index 3c26883fb122..d2ca352cd24f 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -20,12 +20,21 @@ HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-libs/libev
+RDEPEND="
+ dev-libs/libev
net-dns/c-ares
net-misc/curl[http2,ssl]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_GTest=ON
+ -DCLANG_TIDY_EXE=OFF
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install
- dobin "${S}_build/https_dns_proxy"
+ dobin "${BUILD_DIR}"/https_dns_proxy
}