summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-06-10 08:44:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-06-10 08:50:13 +0200
commit923d7f9355b3f4de6f0559f98e9632c2d42b1c6c (patch)
treeb8e7beefae0bf9d401533b2ff075ae07400290d2
parentdev-libs/libintl: Bump to version 0.19.8 (diff)
downloadgentoo-923d7f9355b3f4de6f0559f98e9632c2d42b1c6c.tar.gz
gentoo-923d7f9355b3f4de6f0559f98e9632c2d42b1c6c.tar.bz2
gentoo-923d7f9355b3f4de6f0559f98e9632c2d42b1c6c.zip
net-misc/wget: Removed old.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/wget/Manifest1
-rw-r--r--net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch76
-rw-r--r--net-misc/wget/wget-1.16.3-r1.ebuild91
-rw-r--r--net-misc/wget/wget-1.16.3-r2.ebuild93
-rw-r--r--net-misc/wget/wget-1.17.1.ebuild89
5 files changed, 0 insertions, 350 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index a822981c29f6..cdb1bc42d942 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,3 +1,2 @@
-DIST wget-1.16.3.tar.xz 1794148 SHA256 67f7b7b0f5c14db633e3b18f53172786c001e153d545cfc85d82759c5c2ffb37 SHA512 2d1fe632bcd116a68ae333278e368cb810081b51d2259ddade602bebf3dd08dee1f51f67c9c7d79d2410e19fe0d48a0b9a1b1a7c7c6eeb47e2840ce6c1a3471c WHIRLPOOL b8fe9880523fc295b092c3b9ff4f9af58c071f55d516903ded66df67722cd27955ad651f6f2f6032b611e5445dd89b8ff97878443abc04d095c29e76f0564490
DIST wget-1.17.1.tar.xz 1894140 SHA256 fe559b61eb9cc01635ac6206a14e02cb51591838c35fa83c7a4aacae0bdd97c9 SHA512 aa13584c94d0911268aeee9d6c7b1a7de259e0ec0f9daebe767e1f45afba097a6e9de09f370e55ead7acc9faa68f189063ac9e3d2d4a8d490f0b4edb6adc19ba WHIRLPOOL 3efbac1862cb6537ea08eeb95dea2f34ca29f6a170c80961ef3037d411458ac343dfd13f2ff056b528e6591fb282eaf4bf1c2113939b25764c39630510b35cf0
DIST wget-1.18.tar.xz 1922376 SHA256 b5b55b75726c04c06fe253daec9329a6f1a3c0c1878e3ea76ebfebc139ea9cc1 SHA512 a3f6fe2f44a8d797659d55cffaf81eb82b770c96222a0ee29bc4931b13846f8d8b9a07806f2197723c873a1248922d59cca5a81869661d9c6c3107447c184338 WHIRLPOOL a9e467f8bd17909485329103c17a27da345421257ce82fdf77ff2e00bdae50b13570506a1887300868e99b608c71598596ee260d86879aaeddad14cbb5ec634d
diff --git a/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch b/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch
deleted file mode 100644
index 9936f1ee1922..000000000000
--- a/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-https://bugs.gentoo.org/560418
-
-fix from upstream
-
-From 075d7556964f5a871a73c22ac4b69f5361295099 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
-Date: Tue, 11 Aug 2015 16:48:08 +0200
-Subject: [PATCH] Fix IP address exposure in FTP code
-
-* src/ftp.c (getftp): Do not use PORT when PASV fails.
-* tests/FTPServer.px: Add pasv_not_supported server flag.
-* tests/Makefile.am: Add Test-ftp-pasv-not-supported.px
-* tests/Test-ftp-pasv-not-supported.px: New test
-
-Fix IP address exposure when automatically falling back from
-passive mode to active mode (using the PORT command). A behavior that
-may be used to expose a client's privacy even when using a proxy.
----
- NEWS | 2 ++
- src/ftp.c | 19 +++++++-----
- tests/FTPServer.pm | 8 +++++
- tests/Makefile.am | 3 +-
- tests/Test-ftp-pasv-not-supported.px | 60 ++++++++++++++++++++++++++++++++++++
- 5 files changed, 84 insertions(+), 8 deletions(-)
- create mode 100755 tests/Test-ftp-pasv-not-supported.px
-
-diff --git a/src/ftp.c b/src/ftp.c
-index 68f1a33..9dab99c 100644
---- a/src/ftp.c
-+++ b/src/ftp.c
-@@ -252,7 +252,6 @@ getftp (struct url *u, wgint passed_expected_bytes, wgint *qtyread,
- char *respline, *tms;
- const char *user, *passwd, *tmrate;
- int cmd = con->cmd;
-- bool pasv_mode_open = false;
- wgint expected_bytes = 0;
- bool got_expected_bytes = false;
- bool rest_failed = false;
-@@ -883,13 +882,19 @@ Error in server response, closing control connection.\n"));
- ? CONERROR : CONIMPOSSIBLE);
- }
-
-- pasv_mode_open = true; /* Flag to avoid accept port */
- if (!opt.server_response)
- logputs (LOG_VERBOSE, _("done. "));
-- } /* err==FTP_OK */
-- }
-+ }
-+ else
-+ return err;
-
-- if (!pasv_mode_open) /* Try to use a port command if PASV failed */
-+ /*
-+ * We do not want to fall back from PASSIVE mode to ACTIVE mode !
-+ * The reason is the PORT command exposes the client's real IP address
-+ * to the server. Bad for someone who relies on privacy via a ftp proxy.
-+ */
-+ }
-+ else
- {
- err = ftp_do_port (csock, &local_sock);
- /* FTPRERR, WRITEFAILED, bindport (FTPSYSERR), HOSTERR,
-@@ -1148,8 +1153,8 @@ Error in server response, closing control connection.\n"));
- }
-
- /* If no transmission was required, then everything is OK. */
-- if (!pasv_mode_open) /* we are not using pasive mode so we need
-- to accept */
-+ if (!opt.ftp_pasv) /* we are not using passive mode so we need
-+ to accept */
- {
- /* Wait for the server to connect to the address we're waiting
- at. */
---
-2.5.1
-
diff --git a/net-misc/wget/wget-1.16.3-r1.ebuild b/net-misc/wget/wget-1.16.3-r1.ebuild
deleted file mode 100644
index 03924089acba..000000000000
--- a/net-misc/wget/wget-1.16.3-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-PYTHON_COMPAT=( python{3_3,3_4} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="https://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 nls ntlm pcre +ssl static test uuid zlib"
-
-LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
- pcre? ( dev-libs/libpcre[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls[static-libs(+)] )
- !gnutls? ( dev-libs/openssl:0[static-libs(+)] )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
- nls? ( sys-devel/gettext )"
-
-REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ftp-pasv-ip.patch #560418
-}
-
-src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
-
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
- econf \
- --disable-assert \
- --disable-rpath \
- $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
- $(use_enable ssl opie) \
- $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable pcre) \
- $(use_enable debug) \
- $(use_with uuid libuuid) \
- $(use_with zlib)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
-}
diff --git a/net-misc/wget/wget-1.16.3-r2.ebuild b/net-misc/wget/wget-1.16.3-r2.ebuild
deleted file mode 100644
index a44cd52ff384..000000000000
--- a/net-misc/wget/wget-1.16.3-r2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-PYTHON_COMPAT=( python{3_3,3_4} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="https://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
-REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
-
-LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
- pcre? ( dev-libs/libpcre[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls[static-libs(+)] )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0[static-libs(+)] )
- libressl? ( dev-libs/libressl[static-libs(+)] )
- )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
- nls? ( sys-devel/gettext )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ftp-pasv-ip.patch #560418
-}
-
-src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
-
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
- econf \
- --disable-assert \
- --disable-rpath \
- $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
- $(use_enable ssl opie) \
- $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable pcre) \
- $(use_enable debug) \
- $(use_with uuid libuuid) \
- $(use_with zlib)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
-}
diff --git a/net-misc/wget/wget-1.17.1.ebuild b/net-misc/wget/wget-1.17.1.ebuild
deleted file mode 100644
index 86a006c0bb5b..000000000000
--- a/net-misc/wget/wget-1.17.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-PYTHON_COMPAT=( python{3_3,3_4} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="https://www.gnu.org/software/wget/"
-SRC_URI="mirror://gnu/wget/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
-REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
-
-LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
- pcre? ( dev-libs/libpcre[static-libs(+)] )
- ssl? (
- gnutls? ( net-libs/gnutls[static-libs(+)] )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0[static-libs(+)] )
- libressl? ( dev-libs/libressl[static-libs(+)] )
- )
- )
- uuid? ( sys-apps/util-linux[static-libs(+)] )
- zlib? ( sys-libs/zlib[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- static? ( ${LIB_DEPEND} )
- test? (
- ${PYTHON_DEPS}
- dev-lang/perl
- dev-perl/HTTP-Daemon
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-SSL
- )
- nls? ( sys-devel/gettext )"
-
-DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- # fix compilation on Solaris, we need filio.h for FIONBIO as used in
- # the included gnutls -- force ioctl.h to include this header
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
-
- if use static ; then
- append-ldflags -static
- tc-export PKG_CONFIG
- PKG_CONFIG+=" --static"
- fi
- econf \
- --disable-assert \
- --disable-rpath \
- $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
- $(use_enable ssl opie) \
- $(use_enable ssl digest) \
- $(use_enable idn iri) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable ntlm) \
- $(use_enable pcre) \
- $(use_enable debug) \
- $(use_with uuid libuuid) \
- $(use_with zlib)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- sed -i \
- -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
- "${ED}"/etc/wgetrc \
- "${ED}"/usr/share/man/man1/wget.1 \
- "${ED}"/usr/share/info/wget.info
-}