summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 09:47:14 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:44:59 +0100
commit92cd580f34fe372a717c77dcf92d41056ad5a870 (patch)
tree7472ef54667524ef764aa448b7f3f97f5b0576bc
parentapp-emulation/qemu-guest-agent: update HOMEPAGE (diff)
downloadgentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.tar.gz
gentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.tar.bz2
gentoo-92cd580f34fe372a717c77dcf92d41056ad5a870.zip
dev-python/git-python: Version bump to 2.1.7
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6161
-rw-r--r--dev-python/git-python/Manifest1
-rw-r--r--dev-python/git-python/git-python-2.1.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index e85c7a11b164..574535e89b94 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -1,3 +1,4 @@
DIST GitPython-1.0.2.tar.gz 387615 SHA256 85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84 SHA512 faff50d5272158f1d05d932e7827c05272f9a28772aabbcabd631b735bb4d8306d2861d13c327d02a4c554bd9a9902c473fb282318036405497dd8bf0fcc51a8 WHIRLPOOL c12e850114d101faa673d4d87e6885b1d7cd55544d335e08d4579c160e4d8ef488dd09359cfbd9a39e11f4555b8cb3cd2bfec214c95883b5a83565ad1e28b403
DIST GitPython-2.0.6.tar.gz 406234 SHA256 282268c4eab0d53a44fe40af038625be307560370c38d2882f3b6763642785db SHA512 97a64e715b2d78d58542de5adcf679aa73a64bae49b6c76c2ac56a8ffaa0f712f80b239a39408d79395bf4c3a6e5ca7c5ee21a166a8b4da597c898f92a5a123d WHIRLPOOL c0a540f2b84059a038127182d515ce8c91b93fde4328ed32c7f57d847c2f7bc62dfd0275ead5c23498f4e8ba756d9c2067b2d608167031b352416b197117ed44
DIST GitPython-2.1.5.tar.gz 420147 SHA256 5c00cbd256e2b1d039381d4f7d71fcb7ee5cc196ca10c101ff7191bd82ab5d9c SHA512 40350434edb12d3335ea6a9f0176df4eff0564c8c8388f6a9769d2ab9e46c708625849a079eaf4e1c5aa9eaf10d91f439097277d67e3c6b5e9659a88bfcdd4e2 WHIRLPOOL 62df18eca5400b96bb99939256f3e601a48241ad79b360eb3ff570c1faf48d48e449d319b5860859ac0f974a21038f9b572418f5a14000c22f2f63f9d631ea28
+DIST GitPython-2.1.7.tar.gz 426362 SHA256 13c7cd99c2bf277fc99accfc25148752fa90e7cc6c6d08a3f01d229dacb461d9 SHA512 3081fcf4944d49042fa95b55f1f0a152b405830fa592fbe546710798388e2bd7422bd2c62f5a7545f0820693fe1948ef31e1485d7b6bc2b37f2b807962e7da83 WHIRLPOOL dd906127173dd6c837b5f9c54295a79f9e9f84a7b833fdbebb70827a8e5dfbc1919ed9e81f7a9d2445f0d6ded45209b16ca48a198e623ca5757c7dc09cb87b15
diff --git a/dev-python/git-python/git-python-2.1.7.ebuild b/dev-python/git-python/git-python-2.1.7.ebuild
new file mode 100644
index 000000000000..bfa1722cf7ed
--- /dev/null
+++ b/dev-python/git-python/git-python-2.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests only work with the GitPython repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"