summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2016-03-24 11:09:16 -0300
committerGuilherme Amadio <amadio@gentoo.org>2016-03-24 11:10:26 -0300
commit93107b6974084bd968d73c5c2b09a054e433972e (patch)
tree934048bd0972d2988c7a5e0946b7b272ea7b0b18
parentprofiles: mask app-cdr/qmultirecord for removal (diff)
downloadgentoo-93107b6974084bd968d73c5c2b09a054e433972e.tar.gz
gentoo-93107b6974084bd968d73c5c2b09a054e433972e.tar.bz2
gentoo-93107b6974084bd968d73c5c2b09a054e433972e.zip
dev-vcs/gitstats-0_pre131024: fix bug #575946
Gentoo-bug: 575946 Reported-by: Martin Mokrejš Package-Manager: portage-2.2.28
-rw-r--r--dev-vcs/gitstats/files/gitstats-0_pre131024-filter-invalid-unicode.patch11
-rw-r--r--dev-vcs/gitstats/gitstats-0_pre131024.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-vcs/gitstats/files/gitstats-0_pre131024-filter-invalid-unicode.patch b/dev-vcs/gitstats/files/gitstats-0_pre131024-filter-invalid-unicode.patch
new file mode 100644
index 000000000000..4af6f890ec40
--- /dev/null
+++ b/dev-vcs/gitstats/files/gitstats-0_pre131024-filter-invalid-unicode.patch
@@ -0,0 +1,11 @@
+--- gitstats 2016-03-24 10:57:18.000000000 -0300
++++ gitstats.mod 2016-03-24 10:57:11.355016439 -0300
+@@ -321,7 +321,7 @@
+
+ # Collect revision statistics
+ # Outputs "<stamp> <date> <time> <timezone> <author> '<' <mail> '>'"
+- lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getcommitrange('HEAD'), 'grep -v ^commit']).split('\n')
++ lines = getpipeoutput(['git rev-list --pretty=format:"%%at %%ai %%aN <%%aE>" %s' % getcommitrange('HEAD'), 'grep -av ^commit | grep -ax \'.*\'']).split('\n')
+ for line in lines:
+ parts = line.split(' ', 4)
+ author = ''
diff --git a/dev-vcs/gitstats/gitstats-0_pre131024.ebuild b/dev-vcs/gitstats/gitstats-0_pre131024.ebuild
index a4a012c8fdc1..03be6561896c 100644
--- a/dev-vcs/gitstats/gitstats-0_pre131024.ebuild
+++ b/dev-vcs/gitstats/gitstats-0_pre131024.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,6 +26,7 @@ src_prepare() {
sed \
-e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
-i gitstats || die "failed to fix static files path"
+ epatch "${FILESDIR}"/${P}-filter-invalid-unicode.patch
}
src_compile() {