summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 21:24:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 21:24:34 -0600
commit9344605de821b5c1219d2b72e7ce87173417dbc1 (patch)
tree61ae5525a1bf0842082c06704501a1172ed9dcd0
parentdev-python/sqlalchemy: 1.2.2 bup (diff)
downloadgentoo-9344605de821b5c1219d2b72e7ce87173417dbc1.tar.gz
gentoo-9344605de821b5c1219d2b72e7ce87173417dbc1.tar.bz2
gentoo-9344605de821b5c1219d2b72e7ce87173417dbc1.zip
dev-python/stevedore: 1.28.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-1.28.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index b41fad6b06f1..9d8d4000e763 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1 +1,2 @@
DIST stevedore-1.25.1.tar.gz 509014 BLAKE2B 22580ac0e5af56eadd81e7521888e3b2458a1c03a3bdac69df1f2eeef20248f1ddc1748447e3e961b61cbe62ebc939e36c04ff011b7845b3278e18a5fdc9e14e SHA512 f3d2a7360e783c800c3c2488f6adf6f9f76e34e4a4e6f3fc53d2f1114b889c443c13fdf217ddce65a41922dda2c782f19b2077847807c70e732a522fd2166ff0
+DIST stevedore-1.28.0.tar.gz 504872 BLAKE2B 6a9ba88ab950f17898d2dd76d75cd7bc7031cbcf441523863520e15916bc5c255fe6a62444f46b6d9967ec1f5f716420b36cb114995907ec8e2c39110ae7918a SHA512 e148560e255a362a51ce91e8bc2380828ba9a41e1988138bcff2d5b270097cadffdee30f3c98e123d8ced9f6f0ff350b52e793fd400ce6b45095860788bd6b86
diff --git a/dev-python/stevedore/stevedore-1.28.0.ebuild b/dev-python/stevedore/stevedore-1.28.0.ebuild
new file mode 100644
index 000000000000..60311256947d
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.28.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}