summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-08 16:00:08 -0500
committerJames Le Cuirot <chewi@gentoo.org>2018-04-08 22:59:36 +0100
commit935303706906f96d41ac75da3f0ac2dd24b12faf (patch)
tree72455ea708cfebd5cff40cda0dc3880b7b5fe859
parentsys-libs/slang-2.3.2: arm64 stable (bug #651302) (diff)
downloadgentoo-935303706906f96d41ac75da3f0ac2dd24b12faf.tar.gz
gentoo-935303706906f96d41ac75da3f0ac2dd24b12faf.tar.bz2
gentoo-935303706906f96d41ac75da3f0ac2dd24b12faf.zip
dev-lang/scala: clean duplicate patches
Package-Manager: Portage-2.3.28, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/7900
-rw-r--r--dev-lang/scala/files/scala-2.11.1-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.11.11-no-git.patch24
-rw-r--r--dev-lang/scala/files/scala-2.11.2-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.11.4-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.11.6-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.11.7-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.11.8-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.12.1-no-git.patch8
-rw-r--r--dev-lang/scala/files/scala-2.12.1-runner-script.patch4
-rw-r--r--dev-lang/scala/files/scala-2.12.2-no-git.patch4
-rw-r--r--dev-lang/scala/files/scala-2.12.4-no-git.patch4
-rw-r--r--dev-lang/scala/scala-2.11.1-r2.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.11.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.2-r2.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.4-r1.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.4-r2.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.6-r1.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.7-r1.ebuild4
-rw-r--r--dev-lang/scala/scala-2.11.8.ebuild4
-rw-r--r--dev-lang/scala/scala-2.12.1.ebuild4
-rw-r--r--dev-lang/scala/scala-2.12.2.ebuild4
-rw-r--r--dev-lang/scala/scala-2.12.4.ebuild2
22 files changed, 55 insertions, 79 deletions
diff --git a/dev-lang/scala/files/scala-2.11.1-no-git.patch b/dev-lang/scala/files/scala-2.11.1-no-git.patch
index fbec47cd6c69..efef8376a9d1 100644
--- a/dev-lang/scala/files/scala-2.11.1-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.1-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.1-orig/tools/get-scala-commit-date 2014-05-19 21:01:18.000000000 +1000
-+++ scala-2.11.1/tools/get-scala-commit-date 2014-07-06 16:47:04.772397561 +1000
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.1-orig/tools/get-scala-commit-sha 2014-05-19 21:01:18.000000000 +1000
-+++ scala-2.11.1/tools/get-scala-commit-sha 2014-07-06 16:47:25.704741601 +1000
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.11.11-no-git.patch b/dev-lang/scala/files/scala-2.11.11-no-git.patch
deleted file mode 100644
index b1012626c525..000000000000
--- a/dev-lang/scala/files/scala-2.11.11-no-git.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- scala-2.11.8-orig/tools/get-scala-commit-date 2016-03-04 21:57:12.000000000 +1100
-+++ scala-2.11.8/tools/get-scala-commit-date 2016-09-16 10:29:09.215240534 +1000
-@@ -10,8 +10,8 @@
-
- [[ $# -eq 0 ]] || cd "$1"
-
--lastcommitdate=$(git log --format="%ci" HEAD | head -n 1 | cut -d ' ' -f 1)
--lastcommithours=$(git log --format="%ci" HEAD | head -n 1 | cut -d ' ' -f 2)
-+lastcommitdate="2016-03-04"
-+lastcommithours="00:00:00"
-
- # 20120324
- echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.8-orig/tools/get-scala-commit-sha 2016-03-04 21:57:12.000000000 +1100
-+++ scala-2.11.8/tools/get-scala-commit-sha 2016-09-16 10:29:45.566119137 +1000
-@@ -12,7 +12,7 @@
-
- # printf %016s is not portable for 0-padding, has to be a digit.
- # so we're stuck disassembling it.
--hash=$(git log -1 --format="%H" HEAD)
-+hash="1706a37eb84ec252aea77bccebad3e48448534ad"
- hash=${hash#g}
- hash=${hash:0:10}
- echo "$hash"
diff --git a/dev-lang/scala/files/scala-2.11.2-no-git.patch b/dev-lang/scala/files/scala-2.11.2-no-git.patch
index 87dbb8e4c8e3..56dd69a24b22 100644
--- a/dev-lang/scala/files/scala-2.11.2-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.2-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.2-orig/tools/get-scala-commit-date 2014-07-21 17:50:18.000000000 +1000
-+++ scala-2.11.2/tools/get-scala-commit-date 2014-10-04 18:33:48.729779264 +1000
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.2-orig/tools/get-scala-commit-sha 2014-07-21 17:50:18.000000000 +1000
-+++ scala-2.11.2/tools/get-scala-commit-sha 2014-10-04 18:34:32.541990564 +1000
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.11.4-no-git.patch b/dev-lang/scala/files/scala-2.11.4-no-git.patch
index 275c140a2a10..f7a78d38c2cf 100644
--- a/dev-lang/scala/files/scala-2.11.4-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.4-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.4-orig/tools/get-scala-commit-date 2014-10-23 20:06:36.000000000 +1100
-+++ scala-2.11.4/tools/get-scala-commit-date 2014-11-26 21:54:26.064081533 +1100
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.4-orig/tools/get-scala-commit-sha 2014-10-23 20:06:36.000000000 +1100
-+++ scala-2.11.4/tools/get-scala-commit-sha 2014-11-26 21:55:12.248629566 +1100
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.11.6-no-git.patch b/dev-lang/scala/files/scala-2.11.6-no-git.patch
index 231632a3b177..4bc7b7f9fae5 100644
--- a/dev-lang/scala/files/scala-2.11.6-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.6-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.6-orig/tools/get-scala-commit-date 2015-02-25 12:22:22.000000000 +1100
-+++ scala-2.11.6/tools/get-scala-commit-date 2015-04-17 20:32:27.899791213 +1000
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.6-orig/tools/get-scala-commit-sha 2015-02-25 12:22:22.000000000 +1100
-+++ scala-2.11.6/tools/get-scala-commit-sha 2015-04-17 20:32:03.655808474 +1000
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.11.7-no-git.patch b/dev-lang/scala/files/scala-2.11.7-no-git.patch
index ea337b23849b..f8ca464002e0 100644
--- a/dev-lang/scala/files/scala-2.11.7-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.7-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.7-orig/tools/get-scala-commit-date 2015-06-23 04:27:36.000000000 +1000
-+++ scala-2.11.7/tools/get-scala-commit-date 2015-07-04 11:53:24.696520666 +1000
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.7-orig/tools/get-scala-commit-sha 2015-06-23 04:27:36.000000000 +1000
-+++ scala-2.11.7/tools/get-scala-commit-sha 2015-07-04 11:51:15.598526730 +1000
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.11.8-no-git.patch b/dev-lang/scala/files/scala-2.11.8-no-git.patch
index b1012626c525..b577dcbc8df3 100644
--- a/dev-lang/scala/files/scala-2.11.8-no-git.patch
+++ b/dev-lang/scala/files/scala-2.11.8-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.11.8-orig/tools/get-scala-commit-date 2016-03-04 21:57:12.000000000 +1100
-+++ scala-2.11.8/tools/get-scala-commit-date 2016-09-16 10:29:09.215240534 +1000
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,8 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -11,8 +11,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.11.8-orig/tools/get-scala-commit-sha 2016-03-04 21:57:12.000000000 +1100
-+++ scala-2.11.8/tools/get-scala-commit-sha 2016-09-16 10:29:45.566119137 +1000
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -12,7 +12,7 @@
# printf %016s is not portable for 0-padding, has to be a digit.
diff --git a/dev-lang/scala/files/scala-2.12.1-no-git.patch b/dev-lang/scala/files/scala-2.12.1-no-git.patch
index f5439e35aadc..94cf149da7b6 100644
--- a/dev-lang/scala/files/scala-2.12.1-no-git.patch
+++ b/dev-lang/scala/files/scala-2.12.1-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.12.1-orig/tools/get-scala-commit-date 2016-12-05 20:45:09.000000000 +1100
-+++ scala-2.12.1/tools/get-scala-commit-date 2016-12-27 16:41:41.695942033 +1100
+--- a/tools/get-scala-commit-date
++++ b/tools/get-scala-commit-date
@@ -10,13 +10,8 @@
[[ $# -eq 0 ]] || cd "$1"
@@ -16,8 +16,8 @@
# 20120324
echo "${lastcommitdate//-/}-${lastcommithours//:/}"
---- scala-2.12.1-orig/tools/get-scala-commit-sha 2016-12-05 20:45:09.000000000 +1100
-+++ scala-2.12.1/tools/get-scala-commit-sha 2016-12-27 16:44:07.393422207 +1100
+--- a/tools/get-scala-commit-sha
++++ b/tools/get-scala-commit-sha
@@ -10,13 +10,7 @@
[[ $# -eq 0 ]] || cd "$1"
diff --git a/dev-lang/scala/files/scala-2.12.1-runner-script.patch b/dev-lang/scala/files/scala-2.12.1-runner-script.patch
index 9115a9810f67..d622e651ef8f 100644
--- a/dev-lang/scala/files/scala-2.12.1-runner-script.patch
+++ b/dev-lang/scala/files/scala-2.12.1-runner-script.patch
@@ -1,5 +1,5 @@
---- scala-2.12.1-orig/src/compiler/scala/tools/ant/templates/tool-unix.tmpl 2016-12-05 20:45:09.000000000 +1100
-+++ scala-2.12.1/src/compiler/scala/tools/ant/templates/tool-unix.tmpl 2016-12-28 11:46:29.120052198 +1100
+--- a/src/compiler/scala/tools/ant/templates/tool-unix.tmpl
++++ b/src/compiler/scala/tools/ant/templates/tool-unix.tmpl
@@ -197,14 +197,11 @@
# to java to suppress "." from materializing.
if [[ "$usebootcp" == "true" ]]; then
diff --git a/dev-lang/scala/files/scala-2.12.2-no-git.patch b/dev-lang/scala/files/scala-2.12.2-no-git.patch
index 1c09bf6ba866..5c921270bd50 100644
--- a/dev-lang/scala/files/scala-2.12.2-no-git.patch
+++ b/dev-lang/scala/files/scala-2.12.2-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.12.2-orig/project/VersionUtil.scala 2017-04-13 02:16:08.000000000 +1000
-+++ scala-2.12.2/project/VersionUtil.scala 2017-05-04 23:45:50.715285243 +1000
+--- a/project/VersionUtil.scala
++++ b/project/VersionUtil.scala
@@ -80,18 +80,8 @@
val (dateObj, sha) = {
diff --git a/dev-lang/scala/files/scala-2.12.4-no-git.patch b/dev-lang/scala/files/scala-2.12.4-no-git.patch
index 04e620bcee26..0114e1d42b9e 100644
--- a/dev-lang/scala/files/scala-2.12.4-no-git.patch
+++ b/dev-lang/scala/files/scala-2.12.4-no-git.patch
@@ -1,5 +1,5 @@
---- scala-2.12.4-orig/project/VersionUtil.scala 2017-10-11 09:05:11.000000000 +1100
-+++ scala-2.12.4/project/VersionUtil.scala 2018-01-29 15:58:57.205758665 +1100
+--- a/project/VersionUtil.scala
++++ b/project/VersionUtil.scala
@@ -2,7 +2,7 @@
import sbt.{stringToProcess => _, _}
diff --git a/dev-lang/scala/scala-2.11.1-r2.ebuild b/dev-lang/scala/scala-2.11.1-r2.ebuild
index 790709d5036d..e2bdb4138ba4 100644
--- a/dev-lang/scala/scala-2.11.1-r2.ebuild
+++ b/dev-lang/scala/scala-2.11.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.1-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.11.ebuild b/dev-lang/scala/scala-2.11.11.ebuild
index d0bce664a497..9809a7fcfcb2 100644
--- a/dev-lang/scala/scala-2.11.11.ebuild
+++ b/dev-lang/scala/scala-2.11.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -131,7 +131,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.8-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.2-r2.ebuild b/dev-lang/scala/scala-2.11.2-r2.ebuild
index ffdaa3e3ca82..200cda5accde 100644
--- a/dev-lang/scala/scala-2.11.2-r2.ebuild
+++ b/dev-lang/scala/scala-2.11.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.2-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.4-r1.ebuild b/dev-lang/scala/scala-2.11.4-r1.ebuild
index 067a60efc007..5ff29fa215e6 100644
--- a/dev-lang/scala/scala-2.11.4-r1.ebuild
+++ b/dev-lang/scala/scala-2.11.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.4-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.4-r2.ebuild b/dev-lang/scala/scala-2.11.4-r2.ebuild
index 2ce90ddd329c..6015a9c1b7c5 100644
--- a/dev-lang/scala/scala-2.11.4-r2.ebuild
+++ b/dev-lang/scala/scala-2.11.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.4-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.6-r1.ebuild b/dev-lang/scala/scala-2.11.6-r1.ebuild
index 16f6ccbb8cfe..b31e50091cd4 100644
--- a/dev-lang/scala/scala-2.11.6-r1.ebuild
+++ b/dev-lang/scala/scala-2.11.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.6-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.7-r1.ebuild b/dev-lang/scala/scala-2.11.7-r1.ebuild
index a0adcc1965c3..25ec70aafff7 100644
--- a/dev-lang/scala/scala-2.11.7-r1.ebuild
+++ b/dev-lang/scala/scala-2.11.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.7-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.11.8.ebuild b/dev-lang/scala/scala-2.11.8.ebuild
index 140be797d660..ae3518042cf2 100644
--- a/dev-lang/scala/scala-2.11.8.ebuild
+++ b/dev-lang/scala/scala-2.11.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -129,7 +129,7 @@ java_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- epatch "${FILESDIR}/${P}-no-git.patch"
+ epatch "${FILESDIR}/${PN}-2.11.8-no-git.patch"
# Note: to bump scala, some things to try are:
# 1. update all the sha1s in JURI
# 2. remove the https://dev.gentoo.org/~gienah/snapshots/${P}-maven-deps.tar.gz from SRC_URI
diff --git a/dev-lang/scala/scala-2.12.1.ebuild b/dev-lang/scala/scala-2.12.1.ebuild
index 38b815fd3f62..f38b2a17af21 100644
--- a/dev-lang/scala/scala-2.12.1.ebuild
+++ b/dev-lang/scala/scala-2.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -134,7 +134,7 @@ src_prepare() {
cp -p "${DISTDIR}/${g}" "${S}/${j#${BURI}/*/}" || die
done
# gentoo patch (by gienah) to stop it calling git log in the build
- eapply "${FILESDIR}/${P}-no-git.patch"
+ eapply "${FILESDIR}/${PN}-2.12.1-no-git.patch"
# https://issues.scala-lang.org/browse/SI-10098
eapply "${FILESDIR}/${PN}-2.12.1-runner-script.patch"
diff --git a/dev-lang/scala/scala-2.12.2.ebuild b/dev-lang/scala/scala-2.12.2.ebuild
index 4670aac74258..838d1769cc1e 100644
--- a/dev-lang/scala/scala-2.12.2.ebuild
+++ b/dev-lang/scala/scala-2.12.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -135,7 +135,7 @@ src_prepare() {
done
# gentoo patch (by gienah) to stop it calling git log in the build
- eapply "${FILESDIR}/${P}-no-git.patch"
+ eapply "${FILESDIR}/${PN}-2.12.2-no-git.patch"
local SBT_PVR="$(java-config --query=PVR --package=sbt)"
sed -e "s@sbt.version=0.13.11@sbt.version=${SBT_PVR}@" \
diff --git a/dev-lang/scala/scala-2.12.4.ebuild b/dev-lang/scala/scala-2.12.4.ebuild
index 062f48a8746e..767fdd498239 100644
--- a/dev-lang/scala/scala-2.12.4.ebuild
+++ b/dev-lang/scala/scala-2.12.4.ebuild
@@ -134,7 +134,7 @@ src_prepare() {
done
# gentoo patch (by gienah) to stop it calling git log in the build
- eapply "${FILESDIR}/${P}-no-git.patch"
+ eapply "${FILESDIR}/${PN}-2.12.4-no-git.patch"
local SBT_PVR="$(java-config --query=PVR --package=sbt)"
sed -e "s@sbt.version=0.13.11@sbt.version=${SBT_PVR}@" \