summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-05 09:28:04 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-05 09:29:22 +0200
commit945d0c29d7eb6684315451cef178677b99c68ca5 (patch)
tree78f47cb5d91daf2392d94084dba21deaea0995ad
parentdev-ruby/rouge: add 3.1.1 and allow install of both slots (diff)
downloadgentoo-945d0c29d7eb6684315451cef178677b99c68ca5.tar.gz
gentoo-945d0c29d7eb6684315451cef178677b99c68ca5.tar.bz2
gentoo-945d0c29d7eb6684315451cef178677b99c68ca5.zip
www-apps/nanoc: add 4.9.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.9.2.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index 3681f502da28..7d506fa778b8 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,2 +1,3 @@
DIST nanoc-4.7.14.gem 256000 BLAKE2B 73b6e038052407f2f698d9d2490476c13f39bca5b9f84bc224cfee64bc7db33efef6da96e6520350c3af958fbe6cb203c3b70ad855acf1e3bb08873fef2d66b7 SHA512 e7413771794e9d2931e3be2a5b5575f7cd207d9b11167a1838496edf34bee4e631c362d9ac50fb0f9dddbe2fd5836b402506565c704838327116a18f0ea34088
DIST nanoc-4.8.10.gem 260608 BLAKE2B 102548bc4616287d7084f81f505f2c1f7fa294a6bfc87c9be80919a4fff6c547ecbc77cc5cb96d7b1fd9414f189cdf62bad9cd4cdf44fe536c60a2eb3c39ac63 SHA512 36080407696d19739af666d9ba4e04d051d679b29b3e8e5d24d893a2d05b05201b74777007781a0da80125a98fd8cc465fb0b78ca0c28c5fc80bdd5229d5fa24
+DIST nanoc-4.9.2.tar.gz 275891 BLAKE2B 6c2ca3b1f00f59762530ccf8dfb37599d89b67819e893fc49252afa0be334c64c0c2f771f7b05db14d24e264d355870a7308a117823750ba6edd68d82b113357 SHA512 593ed6def82e1c109983e37602a1def0bec0ea7a025d2badd3ddd3c564cb43ef619ea9173e563e32ae3891d4e3de85b5020e83292c5e16e1a6888399213c26cf
diff --git a/www-apps/nanoc/nanoc-4.9.2.ebuild b/www-apps/nanoc/nanoc-4.9.2.ebuild
new file mode 100644
index 000000000000..10b86d948ccf
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.9.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.ws/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/cri-2.8:0
+ dev-ruby/ddmemoize:1
+ dev-ruby/ddmetrics:1
+ dev-ruby/ddplugin:1
+ =dev-ruby/hamster-3*
+ >=dev-ruby/parallel-1.12:1
+ dev-ruby/ref:2
+ >=dev-ruby/slow_enumerator_tools-1.1.0:1
+ >=dev-ruby/tomlrb-1.2:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/rdoc
+ dev-ruby/rouge:2
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid tests requiring a network connection
+ rm -f test/checking/checks/test_{css,html}.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm spec/nanoc/deploying/fog_spec.rb \
+ spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{markaby,rainpress}.rb || die
+
+
+ # Use useable tmp dir
+ sed -i -e 's:/tmp/whatever:'${T}'/whatever:' spec/nanoc/base/checksummer_spec.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
+ sed -i -e '/does not crash when output dir does not exist and/askip "gentoo"' spec/nanoc/cli/commands/view_spec.rb || die
+ sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}