summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-08-14 10:57:59 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-08-14 11:01:03 -0500
commit9475103e8faf002aef0a0e4e877b9d28936391e2 (patch)
tree4b4e2eaf9eaf8396e06d921a64b2fb510510a3a4
parentkde-frameworks: Drop KDE Frameworks 5.36.0 (diff)
downloadgentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.tar.gz
gentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.tar.bz2
gentoo-9475103e8faf002aef0a0e4e877b9d28936391e2.zip
sci-libs/nanoflann: initial commit; add version 1.2.3 to the tree
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--sci-libs/nanoflann/Manifest1
-rw-r--r--sci-libs/nanoflann/metadata.xml22
-rw-r--r--sci-libs/nanoflann/nanoflann-1.2.3.ebuild33
3 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/nanoflann/Manifest b/sci-libs/nanoflann/Manifest
new file mode 100644
index 000000000000..09abb93da95d
--- /dev/null
+++ b/sci-libs/nanoflann/Manifest
@@ -0,0 +1 @@
+DIST nanoflann-1.2.3.tar.gz 1157793 SHA256 5ef4dfb23872379fe9eb306aabd19c9df4cae852b72a923af01aea5e8d7a59c3 SHA512 01d5226fb669c9ef21e1bd36bddb07c7bf8bbbf9798e90bfa7966de4ae01e05c669c33a73d37340c41c79fcab81c91c3991077d799a211985b2d0a2a365a8878 WHIRLPOOL 2a1c9a21dbd7571e4c680a2b5e3636086df4e06142d885b390983228a3cf3d36f01d0389fe712f1d9a9106a55887353a1ea7c057a289c727e98b9bf5308c1b20
diff --git a/sci-libs/nanoflann/metadata.xml b/sci-libs/nanoflann/metadata.xml
new file mode 100644
index 000000000000..054bd6c64ebc
--- /dev/null
+++ b/sci-libs/nanoflann/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ nanoflann is a C++ header-only library for building KD-Trees,
+ mostly optimized for 2D or 3D point clouds. This library is a fork
+ (and a subset) of the <pkg>sci-libs/flann</pkg> library.
+ </longdescription>
+ <use>
+ </use>
+ <upstream>
+ <remote-id type="github">jlblancoc/nanoflann</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/nanoflann/nanoflann-1.2.3.ebuild b/sci-libs/nanoflann/nanoflann-1.2.3.ebuild
new file mode 100644
index 000000000000..e82a84965d8b
--- /dev/null
+++ b/sci-libs/nanoflann/nanoflann-1.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++ header-only library for Nearest Neighbor (NN) search wih KD-trees"
+HOMEPAGE="https://github.com/jlblancoc/nanoflann"
+SRC_URI="https://github.com/jlblancoc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/eigen:*"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ # do not compile examples
+ sed -ie 's/add_subdirectory(examples)//g' CMakeLists.txt || die "sed failed"
+}
+
+src_test() {
+ cd "${BUILD_DIR}" && emake -j1 test
+}
+
+src_compile() {
+ :
+}