summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-08 11:05:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-08 12:54:40 +0200
commit94c889dbfa4b8551e0be0ea71cc30fa7b136deaf (patch)
tree3ee69dc88cf2320a2df780785f317d7559f2e9d0
parentdev-lua/luasocket: stable 3.0_rc1-r5 for sparc (diff)
downloadgentoo-94c889dbfa4b8551e0be0ea71cc30fa7b136deaf.tar.gz
gentoo-94c889dbfa4b8551e0be0ea71cc30fa7b136deaf.tar.bz2
gentoo-94c889dbfa4b8551e0be0ea71cc30fa7b136deaf.zip
kde-frameworks/frameworkintegration: 5.73.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.73.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 35d4e6fba764..78c927542c3c 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34
DIST frameworkintegration-5.72.0.tar.xz 1754456 BLAKE2B 3d7be178b96b429c06e9de7a0668abe04de619e8e888d5889c09c00f281b3ddb2ddfb7eb8e54b820cb3893e55d7b3b22263791938209eb028d79c8b6a00b3112 SHA512 2b3da662fcb4b7f64597c4d69d0f8988466353a5064ecae80a4f82bb6f8b3d8b849aef83dce83cf6fc53577f47daee345d439d761548ff0b5f16f38d0b762df0
+DIST frameworkintegration-5.73.0.tar.xz 1754424 BLAKE2B 1f704d1f3e10c8eef0244defb8e5bbc007b48a921f1e209d1625c17b39ca491e7b804b6ca2fbba7ff8375b8b4f359683dcd98190b25d275cf4b0e77b2e5088e9 SHA512 23366afa4ac57a9b642f93eac2a4bb31ca18afbc1073688bd9e95e317a9b0f3f7854311948ab962e536eea9d04a07411ac7bf1d5863fe79e7d82819761130cfd
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.73.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.73.0.ebuild
new file mode 100644
index 000000000000..2aee64430b07
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.73.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}