summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-27 23:55:19 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-28 00:04:20 +0300
commit94cc141b1a1719a648d7794f265b094790b1f8b2 (patch)
tree0b3b39eced36781552431f978dbaff14fbd85d42
parentmedia-plugins/gst-plugins-rtmp: bump to 1.14.5 for upstream bug fixes (diff)
downloadgentoo-94cc141b1a1719a648d7794f265b094790b1f8b2.tar.gz
gentoo-94cc141b1a1719a648d7794f265b094790b1f8b2.tar.bz2
gentoo-94cc141b1a1719a648d7794f265b094790b1f8b2.zip
media-plugins/gst-plugins-smoothstreaming: bump to 1.14.5 for upstream bug fixes
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index 9fd3b6a7d640..b4e19d1a028f 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1 +1,2 @@
DIST gst-plugins-bad-1.14.3.tar.xz 4678316 BLAKE2B b37d90e04a6bdb01e4f512df67e00790979e4b71fa6730092b4c16dbaf005cf94e09a454ed6e962faa3aaef02c2b811ad1899c3c8153b4ab3bf6d9b5f62998cf SHA512 3e92b33b43181d76bf206496c2fe0f84042c486f854f4fdba7efedc3489874944cef00eb2fd9fd7056d749be17c2b237caffc32800d7063615b30bac7226fbb7
+DIST gst-plugins-bad-1.14.5.tar.xz 4686916 BLAKE2B b22377fbadf54828e86cc4e0bb17fb9b25efe4394c64eeceb228084e58d0db595622670c6c0a2d87fb760fce34974f9e425a2b810460465130ce1a4c2c679e7d SHA512 64d2a9f6203fbeb3db19816f936f4db32dd8bb7d1f4ce1f958ae795f008e72946e8e2e8bcf8c456c33d5567cb66dc34ca95836c52e404835300a3a5f38d52b6b
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.5.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.5.ebuild
new file mode 100644
index 000000000000..3b3c77f7d046
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.14.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux \
+ # gst-libs/gst/isoff:gstisoff
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgsturidownloader-1.0 -lgstapp-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/isoff"
+ libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstisoff-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}