summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-16 13:39:33 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-16 13:39:33 +0200
commit95882b3c2c1c85c803cb88d1db7072825e7585ad (patch)
tree0c3171961cd5e51192f07dd766b1337c48411777
parentmedia-sound/audiocompress: Port to EAPI 7 (diff)
downloadgentoo-95882b3c2c1c85c803cb88d1db7072825e7585ad.tar.gz
gentoo-95882b3c2c1c85c803cb88d1db7072825e7585ad.tar.bz2
gentoo-95882b3c2c1c85c803cb88d1db7072825e7585ad.zip
media-sound/bplay: Port to EAPI 7
Bug: https://bugs.gentoo.org/697274 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-sound/bplay/bplay-0.991.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-sound/bplay/bplay-0.991.ebuild b/media-sound/bplay/bplay-0.991.ebuild
index 2352a1b522c3..0fe9c8a2443a 100644
--- a/media-sound/bplay/bplay-0.991.ebuild
+++ b/media-sound/bplay/bplay-0.991.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
@@ -12,17 +12,18 @@ SRC_URI="http://www.amberdata.demon.co.uk/bplay/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa ~ppc sparc x86"
-IUSE=""
src_compile() {
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" \
- CFLAGS="${CFLAGS} -DUSEBUFFLOCK" bplay || die "emake failed"
+ emake \
+ LDFLAGS="${LDFLAGS}" \
+ CFLAGS="${CFLAGS} -DUSEBUFFLOCK" \
+ CC="$(tc-getCC)" bplay
}
src_install () {
- newbin bplay bplay-bin || die "dobin failed"
- dosym bplay-bin /usr/bin/brec || die "dosym failed"
+ newbin bplay bplay-bin
+ dosym bplay-bin /usr/bin/brec
doman brec.1
newman bplay.1 bplay-bin.1
- dodoc README
+ einstalldocs
}