summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-05 22:12:43 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-05 22:12:43 +0900
commit95a831d738dae3bfb016f4ac2f1e2cb0eeee70b1 (patch)
treebd36ed94ff8df821b453832f4d7bc9ebf1a26b37
parentapp-i18n/fbterm: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-95a831d738dae3bfb016f4ac2f1e2cb0eeee70b1.tar.gz
gentoo-95a831d738dae3bfb016f4ac2f1e2cb0eeee70b1.tar.bz2
gentoo-95a831d738dae3bfb016f4ac2f1e2cb0eeee70b1.zip
app-i18n/fbterm: inherit fcaps
Gentoo-Bug: 566458 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-i18n/fbterm/fbterm-1.7-r2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7-r2.ebuild b/app-i18n/fbterm/fbterm-1.7-r2.ebuild
index a371d7db068a..f23bea99932a 100644
--- a/app-i18n/fbterm/fbterm-1.7-r2.ebuild
+++ b/app-i18n/fbterm/fbterm-1.7-r2.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit autotools
+inherit autotools fcaps
DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
HOMEPAGE="https://code.google.com/p/fbterm"
@@ -12,11 +12,10 @@ SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.go
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="caps gpm video_cards_vesa"
+IUSE="gpm video_cards_vesa"
RDEPEND="media-libs/fontconfig
media-libs/freetype:2
- caps? ( sys-libs/libcap )
gpm? ( sys-libs/gpm )
video_cards_vesa? ( dev-libs/libx86 )"
DEPEND="${RDEPEND}
@@ -25,6 +24,10 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${PN}-gcc6.patch )
+FILECAPS=(
+ cap_sys_tty_config+ep usr/bin/${PN}
+)
+
src_prepare() {
sed -i "s|tic|tic -o '\$(DESTDIR)\$(datadir)/terminfo'|" terminfo/Makefile.am
@@ -41,14 +44,12 @@ src_configure() {
src_install() {
default
- if use caps; then
- setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/${PN}
- else
- fperms u+s /usr/bin/${PN}
- fi
+ use filecaps || fperms u+s /usr/bin/${PN}
}
pkg_postinst() {
+ fcaps_pkg_postinst
+
elog "${PN} won't work with vga16fb. You have to use other native"
elog "framebuffer drivers or vesa driver."
elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."