summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 19:12:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 22:06:06 +0100
commit95f3ee1b5604b14c9513b3551350ea24bb98870e (patch)
tree7eda88befb4ad0ff00e9ddfa3b6d6dbdb4786d7b
parentdev-python/xlsxwriter: Version Bump (diff)
downloadgentoo-95f3ee1b5604b14c9513b3551350ea24bb98870e.tar.gz
gentoo-95f3ee1b5604b14c9513b3551350ea24bb98870e.tar.bz2
gentoo-95f3ee1b5604b14c9513b3551350ea24bb98870e.zip
dev-python/Babel: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/Babel/Babel-2.2.0.ebuild50
-rw-r--r--dev-python/Babel/Manifest1
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.2.0.ebuild b/dev-python/Babel/Babel-2.2.0.ebuild
new file mode 100644
index 000000000000..55f37a6f30db
--- /dev/null
+++ b/dev-python/Babel/Babel-2.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ export BUILD_DIR
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 578cf1b1b8c8..5d85570e3514 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,2 +1,3 @@
DIST Babel-2.0.tar.gz 3415906 SHA256 44988df191123065af9857eca68e9151526a931c12659ca29904e4f11de7ec1b SHA512 9f12573d97f688baf0d1fc0f61055e34b67964054e70c8a6c286a8b0e42ce58da4d9c8cf54f94e51b47a5256cc4504a14bea497bd626cfad8c860d952e7a5e18 WHIRLPOOL e08b0d2d6192321f653200b9e4e96d898c12ea8176f7e0fb7c2144d3dfb6c4b6c12b85833b05b1a5e2d9ed8cec3712d09c3b0a1822ca9cc7ea4bf1cb24dac3f3
DIST Babel-2.1.1.tar.gz 3437647 SHA256 7fb6d50effe88a087feb2036cb972fd7a893bf338361516f1a55a820bf7b5248 SHA512 ec7ebb8648101588eecc72913adc45c0593ed6ee5f10874edcd4b932959f9552edcecc8e2ec966dae6ef5e8adb23341f1a4f87ea2d9e6cbba57a9b8b0a352a94 WHIRLPOOL 812badf14a74fa391851aaae048ec5d815d6d8f7abce8b918f036243cc45d91ca97281614c2ef139797719077ef4880cfafce88e9d718b3cd633ed7303e4cfd7
+DIST Babel-2.2.0.tar.gz 6334150 SHA256 d8cb4c0e78148aee89560f9fe21587aa57739c975bb89ff66b1e842cc697428f SHA512 99771f8d34303f977858926ae70f4f3a5e0a0cd7e223a7f9e64364bfd2837356daf0676b06edf7cc11913f41d973bd41e7dcf5afac0f34aca0bf7558acf93802 WHIRLPOOL 7e0c8e2e78fbae776519ea8fd802806c66d7a13426a3de9b6bd1c16c07358fe7c8dd3991c88912570e27337ec8a192a753f9ef687524a398a376a401b286fd81