summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-17 09:30:37 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-17 09:30:37 +0100
commit968ad585fa5132313268219a57a22d106b82a463 (patch)
tree0c78cfbd47f98f5aa8a9828d0fad2a1dd758e0b2
parentdev-python/polygon: Remove old (diff)
downloadgentoo-968ad585fa5132313268219a57a22d106b82a463.tar.gz
gentoo-968ad585fa5132313268219a57a22d106b82a463.tar.bz2
gentoo-968ad585fa5132313268219a57a22d106b82a463.zip
dev-python/genshi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/genshi/Manifest1
-rw-r--r--dev-python/genshi/files/genshi-0.7.5-fix-py3.10.patch233
-rw-r--r--dev-python/genshi/genshi-0.7.5.ebuild38
3 files changed, 0 insertions, 272 deletions
diff --git a/dev-python/genshi/Manifest b/dev-python/genshi/Manifest
index c44760ccf218..dbc2ad197317 100644
--- a/dev-python/genshi/Manifest
+++ b/dev-python/genshi/Manifest
@@ -1,2 +1 @@
-DIST Genshi-0.7.5.tar.gz 266071 BLAKE2B 007a094f8ce9aa17209a2c1c7241eb5eb50c3be3439fa2066ac7ceab88fa4dccbcaa11809042445e23ad1ce106b2e9efa825ac11de03038f07b421e9b93c03f6 SHA512 b5be34094e2eea8f5fc373097414dc77ddfe0ab0a82901b6fd87af558cf62420f690fb39bff2d13bde3f7fef5ef000697372996877b48187ed068227dab59119
DIST Genshi-0.7.6.tar.gz 268913 BLAKE2B c54930023c4cd45e24f44baa62f3cc3fe887c5bfd5feb9f7c694cea9bd500cd8c0cea0ed7a60035fb58de9b933199f54ada2a14edff9f5a1b1f63203d10ac7c8 SHA512 a05e82b2b1b9321153a202e5926a26795ebc7c56ee13b8c6da197007a00711efcc7f8ebfb759446c4c2cb99e7e92a6f689576f9ef1f766aa42e0dab86fd5e335
diff --git a/dev-python/genshi/files/genshi-0.7.5-fix-py3.10.patch b/dev-python/genshi/files/genshi-0.7.5-fix-py3.10.patch
deleted file mode 100644
index fea4e6434b26..000000000000
--- a/dev-python/genshi/files/genshi-0.7.5-fix-py3.10.patch
+++ /dev/null
@@ -1,233 +0,0 @@
-From: Felix Schwarz <felix.schwarz@oss.schwarz.eu>
-https://github.com/edgewall/genshi/pull/49
-
---- a/genshi/util.py
-+++ b/genshi/util.py
-@@ -119,7 +119,6 @@ def _insert_item(self, item):
-
- def _manage_size(self):
- while len(self._dict) > self.capacity:
-- olditem = self._dict[self.tail.key]
- del self._dict[self.tail.key]
- if self.tail != self.head:
- self.tail = self.tail.prv
-
---- a/genshi/core.py
-+++ b/genshi/core.py
-@@ -20,7 +20,8 @@
-
- import six
-
--from genshi.util import plaintext, stripentities, striptags, stringrepr
-+from genshi.compat import stringrepr
-+from genshi.util import stripentities, striptags
-
- __all__ = ['Stream', 'Markup', 'escape', 'unescape', 'Attrs', 'Namespace',
- 'QName']
---- a/genshi/filters/tests/i18n.py
-+++ b/genshi/filters/tests/i18n.py
-@@ -12,7 +12,6 @@
- # history and logs, available at http://genshi.edgewall.org/log/.
-
- from datetime import datetime
--import doctest
- from gettext import NullTranslations
- import unittest
-
---- a/genshi/filters/tests/test_html.py
-+++ b/genshi/filters/tests/test_html.py
-@@ -11,7 +11,6 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
- import unittest
-
- import six
---- a/genshi/filters/tests/transform.py
-+++ b/genshi/filters/tests/transform.py
-@@ -12,7 +12,6 @@
- # history and logs, available at http://genshi.edgewall.org/log/.
-
- import doctest
--from pprint import pprint
- import unittest
-
- import six
---- a/genshi/input.py
-+++ b/genshi/input.py
-@@ -22,8 +22,6 @@
- import six
- from six.moves import html_entities as entities, html_parser as html
-
--import six
--
- from genshi.core import Attrs, QName, Stream, stripentities
- from genshi.core import START, END, XML_DECL, DOCTYPE, TEXT, START_NS, \
- END_NS, START_CDATA, END_CDATA, PI, COMMENT
---- a/genshi/output.py
-+++ b/genshi/output.py
-@@ -20,7 +20,7 @@
-
- import six
-
--from genshi.core import escape, Attrs, Markup, Namespace, QName, StreamEventKind
-+from genshi.core import escape, Attrs, Markup, QName, StreamEventKind
- from genshi.core import START, END, TEXT, XML_DECL, DOCTYPE, START_NS, END_NS, \
- START_CDATA, END_CDATA, PI, COMMENT, XML_NAMESPACE
-
---- a/genshi/template/base.py
-+++ b/genshi/template/base.py
-@@ -15,7 +15,6 @@
-
- from collections import deque
- import os
--import sys
-
- import six
-
---- a/genshi/template/directives.py
-+++ b/genshi/template/directives.py
-@@ -19,8 +19,7 @@
- from genshi.path import Path
- from genshi.template.base import TemplateRuntimeError, TemplateSyntaxError, \
- EXPR, _apply_directives, _eval_expr
--from genshi.template.eval import Expression, ExpressionASTTransformer, \
-- _ast, _parse
-+from genshi.template.eval import Expression, _ast, _parse
-
- __all__ = ['AttrsDirective', 'ChooseDirective', 'ContentDirective',
- 'DefDirective', 'ForDirective', 'IfDirective', 'MatchDirective',
---- a/genshi/template/interpolation.py
-+++ b/genshi/template/interpolation.py
-@@ -16,7 +16,6 @@
- """
-
- from itertools import chain
--import os
- import re
- from tokenize import PseudoToken
-
---- a/genshi/template/markup.py
-+++ b/genshi/template/markup.py
-@@ -15,7 +15,7 @@
-
- from itertools import chain
-
--from genshi.core import Attrs, Markup, Namespace, Stream, StreamEventKind
-+from genshi.core import Attrs, Markup, Namespace, Stream
- from genshi.core import START, END, START_NS, END_NS, TEXT, PI, COMMENT
- from genshi.input import XMLParser
- from genshi.template.base import BadDirectiveError, Template, \
---- a/genshi/template/text.py
-+++ b/genshi/template/text.py
-@@ -35,7 +35,6 @@
- TemplateSyntaxError, EXEC, INCLUDE, SUB
- from genshi.template.eval import Suite
- from genshi.template.directives import *
--from genshi.template.directives import Directive
- from genshi.template.interpolation import interpolate
-
- __all__ = ['NewTextTemplate', 'OldTextTemplate', 'TextTemplate']
---- a/genshi/tests/core.py
-+++ b/genshi/tests/core.py
-@@ -11,13 +11,12 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
- import pickle
- import unittest
-
- from genshi import core
- from genshi.core import Markup, Attrs, Namespace, QName, escape, unescape
--from genshi.input import XML, ParseError
-+from genshi.input import XML
- from genshi.compat import StringIO, BytesIO, IS_PYTHON2
- from genshi.tests.test_utils import doctest_suite
-
---- a/genshi/tests/input.py
-+++ b/genshi/tests/input.py
-@@ -11,8 +11,6 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
--import sys
- import unittest
-
- from genshi.core import Attrs, Stream
---- a/genshi/tests/output.py
-+++ b/genshi/tests/output.py
-@@ -11,9 +11,7 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
- import unittest
--import sys
-
- from genshi.core import Attrs, Markup, QName, Stream
- from genshi.input import HTML, XML
---- a/genshi/tests/path.py
-+++ b/genshi/tests/path.py
-@@ -11,7 +11,6 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
- import unittest
-
- from genshi.core import Attrs, QName
---- a/genshi/tests/util.py
-+++ b/genshi/tests/util.py
-@@ -11,7 +11,6 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--import doctest
- import unittest
-
- from genshi import util
---- a/genshi/util.py
-+++ b/genshi/util.py
-@@ -19,8 +19,6 @@
-
- import six
-
--from .compat import stringrepr
--
- __docformat__ = 'restructuredtext en'
-
-
---- a/setup.py
-+++ b/setup.py
-@@ -12,11 +12,8 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://genshi.edgewall.org/log/.
-
--from distutils.cmd import Command
- from distutils.command.build_ext import build_ext
- from distutils.errors import CCompilerError, DistutilsPlatformError
--import doctest
--from glob import glob
- import os
- try:
- from setuptools import setup, Extension
-
---- a/genshi/compat.py
-+++ b/genshi/compat.py
-@@ -99,6 +99,13 @@ def get_code_params(code):
-
-
- def build_code_chunk(code, filename, name, lineno):
-+ if hasattr(code, 'replace'):
-+ # Python 3.8+
-+ return code.replace(
-+ co_filename=filename,
-+ co_name=name,
-+ co_firstlineno=lineno,
-+ )
- params = [0, code.co_nlocals, code.co_kwonlyargcount,
- code.co_stacksize, code.co_flags | 0x0040,
- code.co_code, code.co_consts, code.co_names,
diff --git a/dev-python/genshi/genshi-0.7.5.ebuild b/dev-python/genshi/genshi-0.7.5.ebuild
deleted file mode 100644
index 113fce0e118e..000000000000
--- a/dev-python/genshi/genshi-0.7.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Python toolkit for stream-based generation of output for the web"
-HOMEPAGE="https://genshi.edgewall.org/ https://pypi.org/project/Genshi/"
-SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? ( dev-python/six[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests setup.py
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-python_install_all() {
- if use doc; then
- dodoc doc/*.txt
- fi
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}