summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-11 11:39:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-11 12:58:15 -0500
commit97374daa008256a41ba55576cd1ab4c82848528b (patch)
treebe71dd65f2a295ca480737ecb8198123eabda962
parentdev-python/os-brick: 2.8.2 bump (diff)
downloadgentoo-97374daa008256a41ba55576cd1ab4c82848528b.tar.gz
gentoo-97374daa008256a41ba55576cd1ab4c82848528b.tar.bz2
gentoo-97374daa008256a41ba55576cd1ab4c82848528b.zip
dev-python/python-cinderclient: 4.2.1 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 1bb4616dbad5..6faa37aee5be 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,2 +1,3 @@
DIST python-cinderclient-4.1.0.tar.gz 288464 BLAKE2B 492baefef164e74eca662cbde31b77ae751730420782b9926d265548d064cef08e993279482c566f1c810a62f6cda657e59680d511e5633a7c17be8dbc6fe7c1 SHA512 e895e90dd12802c5991bd05c825b712b30bded38a5dd0dc8d845949cc7e76440959a426cb680447496cccdbb0d5aa31f3b982838a91c7b36e8e31bbaa3fb7b7a
DIST python-cinderclient-4.2.0.tar.gz 284743 BLAKE2B 2306cbc80cf47086aa0dd545f73adc54cbc6fe162f972f2c5d610f26ecccbd38b0b6f028b8e1a548b63d6dcdd32b26bf3dfdcd8e9e360db0325b024e3bbe7bb0 SHA512 d61a10719fbcffd6562c9b7802ac26e317878f52f5db8a704ef57c8ed9b883eaa3a961c2f29df5746befb82b1a29714fa75082df2deebc305115e103e49eee91
+DIST python-cinderclient-4.2.1.tar.gz 287696 BLAKE2B b79068acfeafd9e8ab85035fcda1cceaacc68d3a847b4d070fcb16efdf103ad362c21196afc0ea23eba6a9110f5e96d8de8e2446889740c9abccd912a972358d SHA512 e72af1163bbd882354aea3b7ecdc36cad0899589430e31006f9b1f5f1d00866c9c0de631d2a94b83b3dc358039069adefef54231ecb191ad167339ca3a37a588
diff --git a/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild b/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild
new file mode 100644
index 000000000000..c89d38330451
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}