summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-19 18:18:18 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-19 18:18:30 +0200
commit976c815ff0d5de29f738fc53c50c90ebb53ddea0 (patch)
treea1a7422cf5fbaacb7483a2e89b2435d0777d6e8e
parentdev-python/pyicu: remove old (diff)
downloadgentoo-976c815ff0d5de29f738fc53c50c90ebb53ddea0.tar.gz
gentoo-976c815ff0d5de29f738fc53c50c90ebb53ddea0.tar.bz2
gentoo-976c815ff0d5de29f738fc53c50c90ebb53ddea0.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.7.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 29dc3172a349..fe5e95acd796 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1 +1,2 @@
DIST brython-3.7.2.tar.gz 10403203 BLAKE2B 1fb7778a961c68a873033321fdf7a5b24f422d52195ff1f0606384c76007ab87a1949ead2ffcd7b660b544a9833acf90b254a542ea8856510579bacd0be8477d SHA512 76bdbc005832b4980e38ff4bf2fd705291eb06ee6b9f0c4b25a90df9ab4e6da6638990abb37ebf526d064f54823a9b4ff387edd919db69b1eb3bfc8ed27d6290
+DIST brython-3.7.3.tar.gz 10403156 BLAKE2B a30c957925149f1b7eb736c1fcacd171dffb5846f6a343227596e759820c794c265befbb04137e797c1eabe8d9f0a3faa93fe425e4b0c13fda4c78b4c4bb1ecd SHA512 f234c7bc67d935e5bd5bfa8e473bccf90245ab4dabccd363bc5e9e01e1c9ea9d95989c5f8b323c158e286ac4a66106eb07722d1fcc82353ad036e35b4fda5669
diff --git a/dev-python/brython/brython-3.7.3.ebuild b/dev-python/brython/brython-3.7.3.ebuild
new file mode 100644
index 000000000000..715ffeb233e1
--- /dev/null
+++ b/dev-python/brython/brython-3.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}