summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-11 16:51:22 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-11 16:51:22 +0200
commit977072bb3d342ca7feb7fd1545c3560a83b637ff (patch)
tree6b2d811463c149576299047f1f765089c4baff0e
parentapp-misc/gcalcli: [QA] Add missing PYTHON_REQUIRED_USE (diff)
downloadgentoo-977072bb3d342ca7feb7fd1545c3560a83b637ff.tar.gz
gentoo-977072bb3d342ca7feb7fd1545c3560a83b637ff.tar.bz2
gentoo-977072bb3d342ca7feb7fd1545c3560a83b637ff.zip
app-misc/pip3line: [QA] Add missing PYTHON_REQUIRED_USE
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-misc/pip3line/pip3line-3.6.0.ebuild5
-rw-r--r--app-misc/pip3line/pip3line-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/app-misc/pip3line/pip3line-3.6.0.ebuild b/app-misc/pip3line/pip3line-3.6.0.ebuild
index 8506a3ba9967..6bc81c630244 100644
--- a/app-misc/pip3line/pip3line-3.6.0.ebuild
+++ b/app-misc/pip3line/pip3line-3.6.0.ebuild
@@ -23,10 +23,11 @@ LICENSE="GPL-3"
SLOT="0"
# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
# It has nothing to do with the SSL/TLS protocol itself.
IUSE="distorm python qscintilla ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
@@ -53,7 +54,7 @@ src_configure() {
)
# distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
+ # in the current distorm64 package
if use distorm; then
mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
diff --git a/app-misc/pip3line/pip3line-9999.ebuild b/app-misc/pip3line/pip3line-9999.ebuild
index 8506a3ba9967..6bc81c630244 100644
--- a/app-misc/pip3line/pip3line-9999.ebuild
+++ b/app-misc/pip3line/pip3line-9999.ebuild
@@ -23,10 +23,11 @@ LICENSE="GPL-3"
SLOT="0"
# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
# It has nothing to do with the SSL/TLS protocol itself.
IUSE="distorm python qscintilla ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
@@ -53,7 +54,7 @@ src_configure() {
)
# distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
+ # in the current distorm64 package
if use distorm; then
mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)